Polylines positions changing during camera movement


Im developing 3d models preview with usage of Cesium. I encounter issue when creating measurements with usage of polylines. During change of camera polylines seems to change positions. Problem is not occuring for points. I’m using chrome/safari on mac.

The easiest way to see issue it’s to preview sandcastle example:

I’m attaching preview gif’s with the issue

ezgif.com-gif-maker (1)

I’ll be glad for any help how to solve issue or what’s it’s causing it :slight_smile:

1 Like

You might be having a Mac-specific problem. I am not seeing any jittery rendering in Chrome 102.0.5005.63 with Intel UHD graphics or in Edge 102.0.1245.30 with NVIDIA RTX A2000.7

Oh yes, it’s possible. I asked couple more peoples to test and it seems like mac related problem. On all tested mac’s problem occurs, on windows/linux systems all worked well.

Any ideas how this problem could be solved?

Agreed. This resembles an issue we’ve been looking into which seems to only occur on M1 hardware. We’ve been pursuing support thread with the WebGL community and Apple to attempt to get to the bottom of the problem. We’ll update that issue with any news.