Problem with emissive materials when using Cesium Sun&sky

Hi, I’m facing problems when using emissive materials in cesium sun sky. When i use fx or emissive materials, its not visible and its transparent. Same issue occurs when using scene capture cube to render a panaroma view and its full white. Problems faced above works fine when i disable cesium sun and sky and create my own directional light. Problem is due to directional light intensity being at 110000 lux in cesium sun sky.
How to fix this issue? Thanks in advance…

The sun is much brighter than all lights that normally appear in a scene. There is a dedicated section about Sun Intensity in the tutorial - does that already answer some of your questions?


Hi @Sharbu,

Along with what Marco said, I recently discovered the white Scene Capture Cubes / Scene Capture 2D issue and wanted to add a note on that.

If you want your Scene Captures to capture correctly with high intensity lighting, change the Capture Source on the Scene Capture to Final Color (LDR) in RGB. This converts the input to a low dynamic range and it should render correctly after that. If you want to adjust the exposure further, add a Post Process volume to the scene.

That being said, it sounds like it might be easier for your purposes to just lower the intensity of CesiumSunSky so that you don’t have to modify your fx and emissive materials as well. You can find instructions for that in the link Marco provided.

1 Like

Scene capture works now. Thanks a lot. but I have one more problem.

The panorama texture looks crazy and patched like blocks. especially the sun position area is bloomy.
Tried various settings with sunlight modifiers, turned off bloom and post process and it still persists. I can’t figure out how to get clear texture.

Yes it did. I missed out that section. Thanks a lot

Hi @Sharbu,

Try turning off auto exposure in the project settings - does that help in this case?


Hi @agallegos

I tried it but it didn’t solve the issue

Hi Sharbu,

The only thing I can suggest is to try to use the SunSky actor (Not CesiumSunSky) and see if you’re still having the same problem. If it only happens with CesiumSunSky, please let me know.

If not, I’m guessing this is a combination of the atmosphere settings and the post processing settings, and this forum may not be the best place to look for help at this point. My knowledge of the post processing and rendering engine of Unreal is fairly limited, so I’d suggest making a post on the Unreal forums and you’ll likely be able to get better help.


Hi @agallegos,

I resolved this issue by disabling post process flag under hidden show flags in scene capture cube details when using Final color (LDR) or other capture source settings. But it produces raw image. Anyway thanks…

1 Like