Problems loading pnts-Files

1. A concise explanation of the problem you're experiencing.

the pointcloud isn't loaded and displayed

I use a tomcat-app server . I see that the json-file is parsed but I don't see a call to the pnts-files. also the jprg-files are loaded.

There isn't any error message in tomcat/google chrome developer console.


mimetype is set in the tomcat server

2. A minimal code example. If you've found a bug, this helps us reproduce and repair it.

I use the identical code from the sandcastle 3d-tile photogrammetry and 3d-tilespoint-cloud in my app

var structureTileset2 = viewer.scene.primitives.add(new Cesium.Cesium3DTileset({
          url : ‘
        showStructure2 = true;

        structureTileset2.readyPromise.then(function() {
          var boundingSphere = structureTileset2.boundingSphere;
, new Cesium.HeadingPitchRange(0.0, -0.5, boundingSphere.radius));
        }).otherwise(function(error) {

3. Context. Why do you need to do this? We might know a better way to accomplish your goal.

I would display the pointcloud data

4. The Cesium version you're using, your operating system and browser.
1-40, Google Chrome

Does the ready promise resolve?

I know that those files are served as gzipped but the browser should be responsible for decoding. You aren’t serving the tileset yourself, right?

Sorry… I’m not too familiar with tomcat.

Hi Sean,

I tried both serving the test-data myself (from the Specs-Directory) and trying to load from your server (for the church-pointcloud example). Both doesn't work.

I wondered because the self-hosted sandcastle works. I used the
CesiumViewer.js in the Apps/CesiumViewer Directory and put the above code-snippet in it and it doesn't work. Do I need any dependencies (require) for the pointcloud-data ?


No dependencies are required.

I tried running Cesium within a local tomcat server myself and didn’t have any problems loading the tileset. I downloaded Tomcat 8.5.24, the Cesium 1.40 release, and then edited Apps/Hello World.html with the code you pasted above.

I’m not really sure what to suggest - if the server isn’t hosted locally there may be some other issue I’m not aware of.