Problems with glTF converter under windows

Hi !

I'm trying to use the glTF converter to display 3D models in Cesium, but I encounter several problems.

1. The online converter creates a file containing "HTTP Error 503. The service is unavailable.", even if the provided Collada file seems valid (opens well in Blender).

2. The 0.8 windows build archive contains no .exe file. Is it corrupt ?

3a. The 0.7 windows build seems to work (if I add msvcp120.dll and msvcr120.dll in the folder), but the .gltf file that it creates contains some absolute links, which get me a "RuntimeError: Failed to load external shader" error on the server:
    "bufferView_29": {
            "buffer": "\\Users\\XXX\\YYY\\ZZZ",
            "byteLength": 67140,
            "byteOffset": 0,
            "target": 34963
Plus I didn't expect any external links since I don't have any images. The sample .gltf provided with Cesium don't have such external links.

3b. When I correct the absolute links to relative links, I still get
"RangeError: Invalid typed array length" in Cesium.
I guess this comes from incompatibilities between the 0.7 converter and cesium 1.0 ?

3c. I thought it may be to purpose of the -b (bundle) option to package everything neatly. But it crashes (collada2gltf.exe has stopped working) when I run the command :
    collada2gltf.exe -f D:\Users\path\input.dae -b D:\Users\path\output

Here's my folder :

The _source folder contains the .dae file I'm trying to convert, all the other files are the result of 3b.

Any help would be greatly appreciated !!

Best regards and thanks for Cesium !



Still trying but still no luck... I even tried to compile under Windows and Ubuntu, but it doesn't seem to work out of the box...

Under windows, I get (after some warnings) this error:
GLTF.h(43) : fatal error C1083: Cannot open include file: 'cstdint': No such file or directory

Under ubuntu 14.04, I seem to run into that C++11 problem, I followed the links on the wiki but wasn't able to complete the steps...

Honestly, I'd prefer not to dig too far into building from source (not used to do it), and would much rather be able to use binaries or at least the web tool. I'm a bit frustrated since I'm not able to do anything with my 3D models inside Cesium for now. Do you have an idea on when I can expect some improvements on this ?

Thanks !


The online converter seems to be working fine. Are you still having issues with it? How big is this model? It could be the server is rejecting it due to size. Can you post it somewhere for us to look at?

For problems with building from, you should contact the maintainers or open an issue there; since that is a separate repository from Cesium.

I checked on the server and the model conversion service had crashed and stopped itself. I’ve started it back up now. There may be something wrong with your model that is crashing the server. Can you provide the model you are trying to convert?


Thanks for the answer.

I tested again with some more models, including some found on internet, and some indeed work as expected.

Here are two models causing problems : (just a cube and a cone, saved with blender) (a bit more complex model, but only one object, and still about 10’000 polys only, saved with cinema4d)

Best regards,


There is an issue with COLLADA v1.5 models. It is currently being looked at but for now only 1.4 models can be converted.