Rendering problem since Cesium 1.45

Since the release of Cesium 1.45 I cannot try the cesium Sandcastle examples and I get this error :

An error occurred while rendering. Rendering has stopped.
RuntimeError: Program failed to link. Link log: error: Too many combined image uniforms, shader storage buffers and fragment outputs

    at new RuntimeError (
    at createAndLinkProgram (
    at initialize (
    at ShaderProgram._bind (
    at beginDraw (
    at Context.draw (
    at DrawCommand.execute (
    at executeCommand (
    at executeTranslucentCommandsSortedMRT (
    at OIT.executeCommands (

So, I don't know if the problem is my GPU or cesium change its rendering requirements ?

My GPU info link :

Hi Hilmi,

Have you updated your drivers?

If so, go to and copy the output here.



Hi Gabby,

Yes the driver is up to date and here the output of webglreport:

Google Photos


I'm having the same issue. I'm new to Cesium and just trying things out. I could run the Demo. I can run some of the Sandcastle examples but for the others I get the same error message.

My webgl report is the same as Hilmi's...exactly.


Can you let me know which examples are causing problems? I don’t see anything in the WebGL report that is an obvious issue.

The biggest change in terms of rendering in Cesium 1.45 was the introduction of log depth. Try turning it off by setting Scene.logarithmicDepthBuffer to false.

Thank you Gabby, now I changed *viewer.scene.logarithmicDepthBuffer =
false; *and all the examples work correctly.

Before all those examples not working :

-3D Models
-3D Models Coloring
-3D Tiles Clipping Planes
-3D Tiles Feature Styling
-3D Tiles Formats
-3D Tiles Interior
-3D Tiles Point Cloud Shading
-CZML Billboard and Label
-CZML Circles and Ellipses
-CZML Colors
-CZML Cones and Cylinders
-CZML Custom Properties
-CZML Model
-CZML Path
-CZML Point - Time Dynamic
-CZML Point
-CZML Polygon - Intervals, Availability
-CZML Polygon
-CZML Polyline
-CZML Position Definitions
-CZML Rectangle
-CZML Reference Properties
-CZML Spheres and Ellipsoids
-CZML Wall
-Callback Property
-Cesium Inspector
-Circles and Ellipses
-Cylinders and Cones
-Distance Display Conditions
-GeoJSON and TopoJSON
-Geometry and Appearances
-Ground Clamping
-Map Pins
-Multi-part CZML
-Particle System Fireworks
-Particle System Tails
-Particle System Weather
-Particle System
-Polyline Dash
-Polyline Volume
-Spheres and Ellipsoids
-Star Burst
-Terrain Clipping Planes

Glad that worked!

I believe this is due too using too many “varying” values in the shaders for older video cards after the addition of log depth. We made some changes (see PR #6828) to reduce them, and that fix will be out with the next release tomorrow.