Rendering Sequence ? Version 1.67


I have a 3DTileSets rendering ok with 1.66 but now I have problems, because parts of the 3DTiles aren’t displayed. I think that this can be caused by the changes from 1.66 to 1.67 especially one of the following:

  • Cesium3DTileset.skipLevelOfDetail is now false by default. #8631
  • glTF models are now rendered using the LEQUALS depth test function instead of LESS . This means that when geometry overlaps, the later geometry will be visible above the earlier, where previously the opposite was true. We believe this is a more sensible default, and makes it easier to render e.g. outlined buildings with glTF. #8646

Is there a workaround to have the former behaviour ? I can’t change the data itself.



If the issue is the skipLevelOfDetail, you can turn that back on in the constructor options when creating your Cesium3DTileset. Have you tried that?

Otherwise, it may help to post a screenshot/video/Sandcastle example of the artifacts you’re seeing.

Is your 3D Tileset created with Context Capture ?

I have checked: it is skipLevelOfDetail → should be set to true

Than you for the hint withthe constructor