Sandcastle broken?

When launching Sandcastle from the main menu, the Sandcastle console only displays ‘Error, first part of bucket-requirejs.html must match first part of bucket.html exactly.’ and nothing renders

Are you running Sandcastle locally? What version of Cesium are you using?
Did you run npm run build first? If not, sometimes that can cause errors.



No, I’m running it from the Cesium web site:

Hmm. The application is working fine for me. Try clearing your cache/cookies. Sometimes that can cause issues when the version of Cesium on the website is updated.
If that doesn’t work, what browser and OS are you using?



Thanks, that solved it!


I’m getting the same error about thousand times. I’ve tried lots of methods (copy the lots of part of bucket.html to the bucket-requirejs.html and I also tried the other way but I can’t understand why this is happening. I’ve worked Apache server and localhost.

How can I solve this problem?

11 Temmuz 2016 Pazartesi 20:44:22 UTC+3 tarihinde Klaus Rheinwald yazdı:

Clearing the Cookies solved it for me

I tried but unfortunately, it didn’t work for me.

I’ve tried to work with the 3D Tiles example file.

I’ve downloaded the new cesium and 3DTiles files and copied them in the localhost files.

But probably Cesium has crashed for this.

Other way;

I install the “Cesium-1.24” and !'ve copied some of the new file but it hasn’t work again.

Actually, I wanna work with the “3DTiles.html”. What shall I do?

6 Eylül 2016 Salı 15:01:29 UTC+3 tarihinde Klaus Rheinwald yazdı:

I have seen this often too. For my laptop, I suspect Kaspersky Internet Security is the cause (it is injecting javascript at various places).
So if you have Kasperky running, you can try to disable by following this: Settings -> Additional -> Network -> Inject scripts into web traffic to interact with web pages



Still didn’t work

If you’re trying to get the Sandcastle 3D Tiles example to work, the Cesium version with 3D Tiles has not yet been released (Coming soon, July 5th!).

To get the Sandcastle example running, build Cesium locally and run Sandcastle from your local build.

Hope that helps,

  • Rachel

I noticed same error on my system with Cesium version 1.72 . Your suggestion has worked for me. Thanks. (Firefox Developer Edition + Windows 10)