Sandcastle Google Earth Enterprise doesn't work?

1. A concise explanation of the problem you’re experiencing.

I am in the process of learning Cesium, and going through the “Beginner” part in Sandcastle.

Looks like I can get most of them working.

But when it comes to the “GoogleEarthEnterprise” one, I can’t get it to work, it gives me the following errors in the console:

Failed to retrieve /proxy/? Using defaults.
An error occurred in “GoogleEarthEnterpriseImageryProvider”: An error occurred while accessing
An error occurred in “GoogleEarthEnterpriseTerrainProvider”: An error occurred while accessing

I cannot tell if the server itself is down, or if there is something wrong somewhere…looks like this url doesn’t work in the Google Earth Client. is what works with Google EC. But it still doesn’t work in Cesium.

2. A minimal code example. If you’ve found a bug, this helps us reproduce and repair it.

The code is what is given in Sandcastle.

var geeMetadata = new Cesium.GoogleEarthEnterpriseMetadata({

url : ‘’,

proxy : new Cesium.DefaultProxy(’/proxy/’)


var viewer = new Cesium.Viewer(‘cesiumContainer’, {

imageryProvider : new Cesium.GoogleEarthEnterpriseImageryProvider({

metadata : geeMetadata


terrainProvider : new Cesium.GoogleEarthEnterpriseTerrainProvider({

metadata : geeMetadata


baseLayerPicker : false


Is the url not valid anymore? I have tried with my own GEE server running on Ubuntu, and I get the same errors with a different URL :frowning:

3. Context. Why do you need to do this? We might know a better way to accomplish your goal.

I would like to connect to a or my Google Enterprise Server, using Cesium.

Is that possible? And if not, why do you have an example in Sandcastle? :slight_smile:

4. The Cesium version you’re using, your operating system and browser.

Cesium 1.38 in Sandcastle, I have tried both on Windows 10 and Mac Sierra 10.12.6, using the latest Chrome browser.

Thank you for any help you can give me!


I’m honestly not sure if the server is down. If I go to I get a 404 error as well. I’m not aware of another URL to try. Do you know one? Maybe try removing the proxy against your own local server. You can additional try running Cesium locally. Please let me know the results!



Hi Gabby!

Thank you so much for your response!

In fact there is another URL:

Thanks to your good advice, I have used local Cesium, and I was able to load GEE from that url, without problem. I was also able to load my own GEE server from an Ubuntu VM to its Windows 10 host. I didn’t have to remove the proxy.

However it still doesn’t work with the Sandcastle tutorial. You might want to fix this, and thus keep the Google Earth Enterprise tutorial in Sandcastle, which is really nice to have (if it works :slight_smile:

This is the Fiddler session output I get with Sandcastle and the new URL:

200 Tunnel to

200 Tunnel to

200 Tunnel to

200 Tunnel to

So no 404, but it still doesn’t load :frowning:

Thanks again for your help, I’m sure I will have more questions in the future!



Hi Martine,

I suspected it was a problem with Sandcastle. Thanks for your help tracking this down! I’ve opened a bug in our website repo so we can get this up and running again.

Thanks again!


Hi,Gabby Getz,
how can i show the Historical image map
the maptile link like this

Hi there,

GEE should still work without a proxy when running on your own local server. If you are still having issues, please open a new thread.