Select box for RectangleGrahics clamped to ground above

Hi, I am having an issue where the green select box is not showing on my entity, when my Rectangle graphics is clamped to ground and the terrain is enabled. When I switch to ellipsoid, the box is then in the correct location.
I have had problems with rectangles in the past where it wouldn’t conform to the terrain, but since i worked that out, I am now having this issue. See images below for example
The second image shows the green box above the graphics which sometimes confuses the user whether they have actually selected the entity or not.


Thank you for the detailed forum post! I can see how this would give the user of your application an unintuitive and frustrating experience.

Do you think that the behavior that you are experiencing relates to the following issue?


I don’t think it does relate exactly to that one. I have had that issue before. It was a while ago, but it came about either because:

  • I tried to add an entity to the screen using mouse position when in 3D mode and terrain enabled.
  • Or I had a setting on one of the entity graphics that causes it to shoot off somewhere random.

Sorry i currently have that same problem, but it is a different one. It is when I have a billboard graphic and change from 3D to 2D mode.