Shader of textured building are black

hello guys,

my project target is oculus mobile platform, but after being app, shader of ion asset building too dark,

how to remove this black shader? any solution?

From the screenshot alone, it looks like this is not really a low-level technical problem with the shaders, but more likely a problem with the overall lighting of the scene. You might want to have a look at threads like How to set lighting that might be related. If this does not help, it could be good to provide further information about your light settings, so that someone from the Cesium For Unreal core team can take a look.

i have tried it. I changed the lux number, as well as changed the exposure, but there is no change. I think this is a problem of material ion assets when processing.

Just to confirm this: It looks like the only light source in this scene is the sun - is that correct? More specifically: When you move the sun so that it shines his light on the side of the building that is currently black, is it then still black?

The point is: The side of the building may appear black, because there is literally zero light on that side of the building. If this is the case, then you could consider inserting additional light sources in the scene. This might be a dim directional light that points at the side of the building that is currently black, or some form of ambient light. (I’m not sooo deply involved in the Unreal Engine specifics - the article at Ambient Cubemaps | Unreal Engine 4.27 Documentation might contain some options, but maybe someone who is more familiar with Unreal could give a more focussed hint here)

Right, only one movable directional light support on mobile platform. But i try add static light, this no make changed. I think this is a lighting limitation on mobile. And texture shader are created early in the process.