"Stair effect" on 3D tiles - solved


I wanted to try how to work with 3D Tiles in Unity. I followed the Unity for Cesium tutorial and it seems to work properly.
I tried to import, from Cesium Ion, into Unity my own 3D models generated with Bentley ContexCapture.
But I encountered a very odd display (see snapshot):

It seems that the coordinate has been truncated. The models displays well on a classic Cesium web platform.
I am using Unity 2021.3.17f1.
Any idea of what went wrong in the process ?

Is your model very far from Unity’s origin? It could be a vertex precision problem, in which case pressing the “Place Georeference Here” button the CesiumGeoreference should help.

Other than that, I’m not sure what might be happening. Perhaps you could share the model and we could take a look?

1 Like

Thanks for the reply.
I will investigate further on this “Place Georeference here” option.
I can also share my model. I put it on Cesium Ion. Is it possible for you to take it from here ? Or have you another solution ?


If the “Place Georeference Here” button on the CesiumGeoreference doesn’t help, please send me a direct message with the Cesium ion asset ID, a token that is able to access it, and your permission to access the tileset for debugging purposes.

Thanks for the solution, it works.
The “Place Georeference Here” button did the job. I surely did not follow your tutorial correctly…
But, if you want to investigate this “Stair Effect”, I can still share my data on Cesium Ion. Let me know.

Good to hear that it worked! Probably not much need to investigate the tileset specifically in that case, because it’s unlikely we can do anything about it. Unity uses single-precision floating point numbers for its matrices, so they become very imprecise when far from the origin. The CesiumOriginShift and CesiumSubScene components can be used to keep the origin near the camera during play. In the Editor, the “Place Georeference Origin Here” button is your best bet.