strange bad problem on Chrome from a couple of days... :(

Hello everyone!

From a couple of days at my home computer i noticed a strange problem (never seen before…) with Chrome browser visualizing my Cesium app : i made a site (that is also in the Cesium Demos) where is possible to visualize flight tracks on Cesium globe.

Yesterday i found that the polyline i used to draw the flight was disappeared. The strange thing is that on Firefox, on Internet Explorer, Opera and Safary it is still working! It works also on Chrome from mobile and from other computers!

It is not working only on my device, with Chrome.

It sounds silly, but I donn’t want to underestimated it because it may hide a more serious problem…and then I’m so, I need to understand! :slight_smile:

A clue that i notice is that in the “Camera.FlyTo” animation on Chrome seems that the camera goes under the terrain and then after some seconds the terrain appears with no track, instead on the other browers the animation is fine and the camera fly well to the correct position.

Another clue is that on Chrome if zooming too much near the terrain it progressively disappear leaving a black hole… is possible to see it in my flight simulator, i attach some example images below!

To better understand i tried visualizing the Cesium Code Examples in Sandbox… the result is that visualizing the polyline example, in Chrome only two lines are showed, in Opera all the four lines!

I am using Cesium 1.17, i tried to upgrade to the 1.19 or also downgrade to 1.14, with the same problem. I also tried to update Chrome to the latest version.

How it is possible? :frowning:


Hmm, thanks for reporting this problem.
What OS are you using? What is your graphics card?

I’m not seeing this problem on my machine. Have you tried clearing your cache? Sometimes that causes weird side effects. We usually run chrome in incognito mode when developing to avoid that.



Hello, thank you for your help!

Consider that a week ago all was working well, i developed the app with chrome! :slight_smile:

PC : Sony Vaio VPCEB2M1E

OS : Windows 7 Home Premium

Graphic card : ATI Mobility Radeon HD 5470

I had just tried with Incognito Mode but without benefits :frowning:

The Polyline sandcastle works fine on a Mac Mini w/ OSX El Capitan, latest Chrome (49) and a very basic video card (Intel HD Graphics 4000 1536 MB).

Yesterday i tried a complete “reset to factory default” of my PC, updating video drivers and reinstall chrome… nothing : the track polyline is disappeared. It’s a real mistery!!

I notice that is possible to see the track as “a ghost” in the yello pin (image below) ! What does it means? Can i launch some debug tool?

Updating your drivers was going to be my next recommendation. haha.
Are there any errors in the console? You said it works in Firefox, right?

I haven’t seen an issue like this before.


Yes with Firefox it works correcly and also with the other browsers! :open_mouth:

With Chrome I have some visualizing errors in each geometric example in sandcastle… in the wall example making the green wall taller is possible to see that it is not visualized but the blue wall is partially hidden by the ghost of the green wall!

It’s incredible, from today also Opera in no more working, visualizing the black hole in the simulator and with the flight tracks disappeared!

How it is possible? are you sure you don’t change nothing? :frowning:

Somebody see the black hole at this link or only me?

The black hole looks like it might be caused by missing terrain tiles. I didn’t see this from my computer.
Are there any errors in the console? There might be a network issue trying to get the terrain tiles from the server.



Hello Hannah, sorry for the late response :

no errors in the console, but this is not a network error because it is systematic, the black hole is always equal to itself!

Seems like the camera look under the terrain. I can’t understand this problem… :frowning:

nobody see this black hole, only me?

try at this link please! - - - >

No black hole on my Mac Mini w/ Chrome. Beautiful app!