TMS services are not loading

I am trying to load the tms data from the following link in unity through following class CesiumTileMapServiceRasterOverlay. Here is the link

It is giving the error
Unable to parse Tile map service XML document.
0x00007ff614ee284d (Unity) StackWalker::GetCurrentCallstack

To clarify, did you actually download the data to your machine before you tried to load it in Cesium for Unity? You can’t load it through that Github URL because it doesn’t actually load as raw data, it’s a webpage.

Hello, I have downloaded the data in my local directory and here is the path.

Still no data is displayed in the unity cesium3DTileset. My cesium version is 0.3.1

I’m able to load the overlay in Cesium v.1.0.0, though I don’t see any reason why it wouldn’t work in your version.

Can you screenshot the components on your game object (both tileset and overlay) so we can try to identify the problem?

here is the screenshot.

You disabled the Cesium3DTileset, so nothing will show up. Raster overlays have to “drape” over tilesets, you can’t just have them exist by themselves.

Oki thanks alot. I have loaded data successfully in my internet pc. After disconnecting from the internet it gives error .
[2023-04-12 08:44:29.254] [error] [TilesetContentManager.cpp:946] An unexpected error occurs when loading tile: Request failed: Cannot connect to destination host

Any suggestions on how to load data on globe offline.

You would have to use your own offline dataset. See this thread for more details: Loading a local tileset file.

Hello I will see the link for offline. I am facing issue like I have loaded my own dataset this time from tms sevices.Note my pc has internet connection. Attaching tms file which is almost same like Natural Earth. It covers only Asia region.
Problem is my unity is not showing globe as well as data.Screen shots are attached for refrence. If u can guide me regarding this.

Your asset ID is set to 0, which is not a valid asset ID. For Cesium World Terrain, please set the ion Asset ID to 1.

I suggest you check out the Cesium for Unity Quickstart and Adding Datasets tutorials. They cover the basic information needed to load your data with Cesium for Unity.

I have sucessfully loaded the natural earth data.Thanks for your guidance

but when I give my own url of tms data no imagery is displayed. Here is the screenshot