UE5 Crash when editing/deleting/saving Cartographic Polygon

Hello all! Thanks for the help in advance.

As the title states we are finding than once a cartographic polygon tool is added in UE5 it cannot be saved. Meaning we can delete it but saving then crashes the editor:

Fatal error: [File:D:\build++UE5\Sync\Engine\Source\Runtime\CoreUObject\Private\Templates\Casts.cpp] [Line: 10] Cast of CesiumCartographicPolygon /Game/Seattle_Project/Levels/Cesium-BingMapAerial.Cesium-BingMapAerial:PersistentLevel.CesiumCartographicPolygon_UAID_3CECEF77A2E62E2901_1946255554 to MetaData failed

Any thoughts on how to debug this?

We are wondering if this has to do with Source Control/Perforce.

Hello @Xite_Matt, welcome to the forum!

To clarify, you’re experiencing a crash when you save your level after adding a cartographic polygon?

Could you try to replicate the issue in a new project, with just Cesium World Terrain and the cartographic polygon in the level? That will help us figure out if it’s something up with your level/project or the plugin itself.

-Alex

Thank you Alex!

Sure thing, for us it’s as simple as adding a new cartographic polygon from cesium, then deleting it.
Then saving = crash. Deleting any others that we are using = crash.

To be clear about our project setup we are also using World Partition.

Further information - this is happening on multiple machines. All using RTX3090 GPUs.

Migrating to other non-source control fresh projects result in the same crash.

Hi @Xite_Matt, thanks for the additional information.

When you delete the polygon, are there any messages in the Output Log?

Also, which version of Cesium for Unreal are you using?

Looks like it’s any Cesium related asset + saving = crash.

The delete is fine - screenshot attached. It’s the saving that crashes it.

We are using Cesium v1.15.1 (the one on the marketplace.)
Just tried v1.16.1-ue5 on the github same crash.

After doing several tests we have determined the issue to be World Partition, it appears that Cesium is not compatible.

You can reproduce this by creating a new world partition level and add cesium then saving. It will always result in a crash.

Hi @Xite_Matt,

Thank you for bringing this to our attention. I’ve created an issue here - World Partition resulting in editor crash with Cesium · Issue #941 · CesiumGS/cesium-unreal · GitHub

Cesium for Unreal is not currently compatible with World Partition, however it shouldn’t be crashing, so we will look into this.

You mentioned you have already tested on multiple machines, and in multiple different projects. One more option you might try is reinstalling Unreal Engine completely. I’d be surprised if it worked, considering you tested on multiple machines, but it’s worth a try.

To help us get to the bottom of this issue, can you provide additional information about your setup? Specifically:

  • System information for the impacted machines
  • Version of Unreal Engine 5 that you are using
  • Any additional plugins or code modifications that you may be using

You can provide this information to me here or post it directly on the issue.

Thanks,
Alex

Hello,

We’ve reproduced this on multiple machines with dual A6000s and RTX3090s and threadripper processors with UE 5.0.2 and 5.0.3 and the public github of 5.1

The crash happens with the polygon likely because it spans multiple load stream zones in World Partition and the one file per actor/external actors part of world partition can’t work with this.