Unit test failed when running them from localhost


I just tried the unit tests packed with the cesium 1.8 archive and it says there are some failures.
Under Firefox, 12 when I run "all tests", 69 when I run "with WebGL validation"

I host this localhost website under IIS, and I run the tests with Firefox and chrome. There are different failures number wether I'm running the unit tests under Firefox or Chrome.

Is that to be expected ?
Are you interested in having the stack trace of those failures (and if so, is there an easy way to copy that trace) ?

That being said, Cesium works fine in both browsers under localhost, so I suppose it's only small failures.


Our goal in Cesium is to have the unit tests fully passing on all supported browsers. Our unit tests are actually pretty demanding and often expose bugs in browsers themselves. For example, until very recently IE 11 would start failing every test halfway through the run because of a bug in IE (which seems to have been fixed in 11.0.18 but I need to test it more to confirm). Firefox has a few failures that we believe are browser bugs, but I don’t know which ones off the top of my head. I would expect Chrome to pass completely.

If you are interested in figuring out why you might have failures on your system, here are my recommendations

  1. Make sure you are using the latest version of each browser. (In IE’s case, be sure all Windows Updates have been applied)

  2. Make sure you are using the latest video card drivers available for your system.

  3. I would recommend trying the supplied development node server instead of IIS, this will be sure that there aren’t server configuration-related failures. IIS should work in most cases, but it’s one less variable to worry about.

If you try those three things and are still getting failures, then it’s possible that there’s a bug in Cesium or a bug in the drivers for your video card that we may need to work around. In order to look into it we would need to know 3 things:

  1. The names of the failing tests

  2. The OS and browser they are failing on

  3. The model video card you are using.

We actually have a GitHub label for issues that are simply test failures. You can also check that out to see if some of the failures you are seeing have already been reported: https://github.com/AnalyticalGraphicsInc/cesium/issues?q=is%3Aopen+is%3Aissue+label%3A%22test+failure%22

Hi Matthew,

I create an issue in github here : https://github.com/AnalyticalGraphicsInc/cesium/issues/2651