Can't pass the tests

Hi all, I’m new here… I’m trying to run the system on my notebook and I have some problems with the tests.

My system is:

  • Ubuntu i686 i686 i386 GNU/Linux.

  • ATI Mobility Radeon HD 3670. (Drivers up to date).

  • Chrome v 26.0.1410.63

This are the results:

Failing 883 specs

View: 3661 specs summary | 883 failing | 0 skipped

the ones who fails are:

  • DynamicScene/*

DeveloperError: scene is required.

  • Renderer/*

TypeError: Cannot call method ‘*’ of undefined.

  • Scene/*

TypeError: Cannot call method ‘createTextureAtlas’ of undefined

  • Widgets/CesiumWidget/CesiumWidget sanity check.

RuntimeError: The browser supports WebGL, but initialization failed.

  • Widgets/SceneModePicker/*

Any ideas for what could be happening??

Thanks in advance!.


It looks like WebGL isn’t initializing correctly in your browser. What does show? (you can select all and copy/paste the text)

Hi Scott… you were right!.. Chrome does not initialize WebGL… I searched a little and I found how to fix that issue, but I ran all the tests again and it keeps failing (and even sometimes, it froze my notebook). Anyway I tried with Firefox and tests fails less than Chrome (just 25).

I concluded that the problem was in my graphics card’s driver with Linux so I switched to Windows and everything works just fine. Now I can start working.

Thanks for responding.