URL sourc has http 503 error in unreal engine

Hi guys
I have a problem with implementing this topic.
I could run those cubes sample with file path address(file:///C:/Users/Almas%20Store/Downloads/Tileset/tileset.json) in URL mode of source and it works very gentle (explained in paragraph 5) but when I tried to set URL by IP and Port I got this warning:

LogHttp: Warning: 000005E0DA302800: request has been successfully processed. URL: http://localhost:8081/tileset.json, HTTP code: 503, content length: 0, actual payload size: 0, elapsed: 2.09s
LogHttp: Warning: 000005E0DA302800 Response Header Connection: close
LogHttp: Warning: 000005E0DA302800 Response Header Proxy-Connection: close
LogHttp: Warning: 000005E0DA302800 Response Header Content-Length: 0

and nothing showed up.

my spetps:
I launch a python server with this command:

python -m http.server 

this server works very nice in browser (I copied this address http://localhost:8081/tileset.json from browser to make sure this is true)
UE version 5.0.3

Excuse me, have you already solved this problem? I may have the same with you below:
Received status code 502 for tileset http://localhost:8003/SampleData/Cesium3DTiles/Hierarchy/BatchTableHierarchy/tileset.json
This server works well in broswer (node.js http-server moudle)

hi honey
NOT Yet :slight_smile:
I could not understand the reason and solution of my problem but I tried this link and the final layer.json file of that progress worked without that error.

1 Like

Although thanks a lot! I have solved my problem but without understanding what I have done😂But it actually loaded successfully in my unreal engine editor with the url below “http://localhost:8000/SampleData/Cesium3DTiles/Batched/BatchedTranslucentOpaqueMix/tileset.json

1 Like

A 503 error (any 5xx error, actually) indicates a problem on the server side. I don’t know why it would work when accessed from a web browser, but not from Cesium for Unreal, though. The only thing I can suggest is that you check the server logs for any hint.

hi guys
finally I could solve my issue
it refers to the server. my PC was connected to the another PC (which was our server)
make sure do not have running any proxy, and then restart Unreal engine.

Thanks a lot!