3D tiles not streaming

tried 3 versions of UE so far…

tiles won’t load, only see the Sky.

got the API key, Cesium ION acct, token, plugin etc


Have you tried the Cesium for Unreal Samples project? You can install it from the Epic Marketplace. That will eliminate the possibility of a bunch of problems related to tokens and the like.

But by far the most common cause of “no tiles” in Cesium for Unreal is that you’re using a remote desktop solution of some sort, and so Unreal has “helpfully” disabled real-time mode. See here:

Hey thanks Kevin.

Cesium tiles are loading fine, I have a few projects running already. The issue seems to be the new Google 3D tiles…

The Cesium for Unreal Samples project has a level with the Google tiles, so it’s still worth confirming that it works there.

We’ve had a continuous stream of people having trouble with the Google tiles, and it has usually come down to forgetting to enable the correct API for their token within the Google Cloud UI, or copying the token into the URL field in Cesium for Unreal incorrectly (such as adding an extra space).

Also check the Output Log. There is sometimes useful information there.

Hey Kevin, the sample project works, thanks!

There is another issue now…when not in play mode, using CTR-L to rotate the Sun, it always snaps back to default, anything I am missing?


I actually wasn’t familiar with that hotkey, but I think the problem is that it tries to rotate the directional light. The CesiumSunSky is a physically realistic sun where the direction is a function of the time of year and time of day. So you can’t change the direction directly. You’re free to use another lighting setup instead of the CesiumSunSky if you want something different.

By the way, in the future, you might want to start new threads for new questions. That will make it easier for others to find the answers later.