3DTilesTileset show’s the problem

A black edge appears in the middle or edge of each tile. It disappears when you get close to it, but it appears at a certain distance. This update only appears after 1.1.0

I can’t tell off of the top of my head which of our changes could have caused the issue. Does your data contains the KHR_materials_unlit extension? If it does not, we changed how we automatically generate normals for meshes. Perhaps enabling “Generate Smooth Normals” on your tileset will make a difference.

I’m not able to reproduce this. Are you seeing it in any of the Cesium for Unity Samples tilesets? Or just in your own?

I don’t quite understand,Where is the KHR materials unlit extension?
The default material I should use。
enabling “Generate Smooth Normals” did not improve the problem。

I used 02_CesiumMelbourne and still found the problem
Is it the unity version? My version is 2021.3.7

Other than that(unrelated to this question),I used my own modified material in the problem before, and the detection Normals failed, but enabling "Generate Smooth Normals has solved the snow I made.

I don’t see anything like that in Melbourne. Have you changed any project settings in Cesium for Unity Samples? What platform / OS and rendering engine are you using? Can you try the latest 2021.3 release of Unity, just to confirm your particular version isn’t somehow causing a problem?

Sorry for taking so long to reply. I created a new urp project and changed the unity version to 2021.3.23f1c1 (LTS). I only imported cesium. This problem still appeared in Melbourne Photogrammetry. It is also easier to observe when the camera lens is far away. I did not find similar problems in other cases, but I also found this problem in large flat areas in my tiles

Is this with the default material? Or are you still using your own custom one?

  • Yes, I just opened the scene and made no other changes.
    In order to eliminate the problem of my pc machine, I replaced a laptop, and the test also saw similar problems in Melbourne Photogrammetry.

Ok, thanks, I can see this too. I wrote an issue to investigate it:

Just to update, a fix for this issue has been included with the Cesium for Unity v1.3.0 release. Feel free to try it out and let us know if there are any further issues.

Thanks, this problem has been solved well in the new version, I will continue to test more datas