Bug? - Textures Dropping between LOD jumps on Tileset in certain areas

I am having an issue where between LOD transitions the texture turns white on top of the Geometry. I have tested the same tile set on an old build using an older version of the Cesium plugin and it works fine so there isn’t any data missing. I am currently using Unreal 5.3 and the latest Cesium plugin version from the Epic Games marketplace. I have attached some images so that it makes more sense. Any help or recommendations would be great!



I’m not sure what would cause that. A few questions:

  1. What tileset is this?
  2. Are you using any raster overlays?
  3. Can you reproduce this problem in the Cesium for Unreal Samples project, or only in your own project?
  4. What version of Cesium for Unreal? I know you said the latest, but it helps to know the exact version. It’s displayed in the lower right corner of the Cesium panel in the UI.
  • it is our own tileset that is stored locally
  • Yes, I am using the Cesium Polygon Raster Overlay
  • No I am not able to replicate it in the Cesium for Unreal Samples project
  • Version 2.4.0

Also it isn’t all the tileset at the middle LOD that turns white, just a few areas. If I run a build of the project I made last year it uses the same File URL for the tileset and works fine so it can’t be that any data is missing as that would show up there. The only difference is the Unreal Version (5.1) and the Cesium version (Not sure what version it was). If I open the unpackaged version of that 5.1 project with the newer Cesium version I get the same thing with the white patches.

Two possibilities for next steps, then.

  1. Can you provide us with a project that reproduces this issue so that we can debug?
  2. Can you try downgrading your project to an older Cesium for Unreal version to confirm that doing so fixes the problem? Identifying in which version it broke will be a big help in identifying what broke. Instructions for installing alternative versions of Cesium for Unreal are found here: GitHub - CesiumGS/cesium-unreal: Bringing the 3D geospatial ecosystem to Unreal Engine

Unfortunately I wouldn’t be able to give you the project / tileset to test on. However I have done some testing and gone through a few versions and found that versions: 2.1, 2.2, and 2.3 work fine but 2.4 is where the issue starts happening. I made a fresh project in Unreal 5.3 to test this so the project settings were all default and nothing had been added other then the Cesium Tile, Georeference and Cesium Sun Sky. Hopefully that helps to pinpoint the bug.

Hi @Laurence01, one more question…
Have you observed this bug on more than one machine? Or are you always developing on the same machine?

(thinking video card or system setup could be part of this)

Hi Brian, I am currently working on it in a small team using Perforce and a couple of us have the visual bug and a couple don’t. The only difference is that they haven’t updated there Cesium Plugin on the marketplace. So yes it has appeared on different machines

So I have done a bit more testing and tried Cesium plugin 2.5 to and that didn’t work either. Also I am trying to get 2.3 to work on the current project but I get this error (Not sure if it is related or just because the later version had been used this whole time and so some new files were introduced or moved around, etc):

We made some substantial changes to texture loading in Cesium for Unreal v2.4.0, so it’s likely your problem was caused by those changes somehow. It’s going to be pretty hard for us to debug if we can’t reproduce it, though. I understand you can’t share your project, but hopefully you can either provide a minimal project that reproduces the issue, or detailed, step-by-step instructions we can follow ourselves in order to recreate it.

As for that linker error… that file isn’t supposed to exist in Cesium for Unreal v2.3, though it does exist in newer versions. I’m not sure why UBT would be trying to link against it if you’re using v2.3. Maybe make sure that your 2.3 install is clean. That is, completely delete the Marketplace/CesiumForUnreal directory before extracting the v2.3 version. Also, make sure that you don’t also have a copy of the plugin in your project’s Plugins directory.

Hi Kevin thanks for helping with the linker error, I assumed that it was something to do with downgrading but again we would really like to use the latest plugin versions. For now I will leave it in 2.4. Is there a way of contacting your team via email and sorting out some kind of Teams call where we can show you the bug and provide a project with a portion of the Tileset?