Light/White pixel flickering on tiles


I have been getting more and more issues with small light/white pixel flickering on dark parts of a cesium tile. This was not a issues some versions back as far as I know. This shows up both in real-time and when rendering something out.

This seem to be an issue on all tiles no matter if its water or on land. Setting “Ignore KHR_materials_unlit” does not change the end result.

Any solution for this?

A bit harder to notice in day time, but its still there.

Thanks in advance, Magnus.

Hi @MetaMagnus,

That’s a strange rendering artifact! I’m not sure if we’ve ever seen that before. Can you provide me with more detail, so I can better understand (and reproduce) your issue?

  • What versions of Unreal Engine and Cesium for Unreal are you using?
  • Just to confirm, this is on Google Photorealistic 3D Tiles?
  • Which version did you start seeing these artifacts?
  • What is the longitude / latitude of the location you’re viewing in these screenshots? Are there other areas in the world where you see this?

Once we have this information, we can troubleshoot from there. Thank you!

Thanks for the quick followup Janine!

  • I am using Unreal Engine 5.3.2 with Cesium 5.3.0 (installed via the launcher)
  • Yes this the Google Photorealistic 3D Tiles.
  • If I remember correctly is started in a smaller fashion some versions back but I can’t be certain when. Was working on a mostly bright scene, so it weren’t such a issue at the time.
  • My Latitue is: 59,908135, Longitude: 10,721472, Height: 99,238093

Thanks again for the quick follow up! :slight_smile:

Hi @MetaMagnus,

Thanks for the info! Unfortunately the Cesium version doesn’t show accurately in the launcher, so we display it on the sidebar to work around it.

But either way, I found one of the “bright spots” that you were seeing underneath this building. I dimmed down the solar time so it was around early morning / evening.

It actually looks like there’s a hole in the photogrammetry. It’s exposing the street behind the walls, which is receiving more light than the wall we’re looking at. That’s why it looks weirdly bright under the building. You can see part of the street / trees through this hole:

The holes in your image look a lot bigger than the ones I found, though. It looks like the tile is form a lower level-of-detail that didn’t properly resolve. I could only guess that the Google session timed out, and prevented the higher level-of-detail from loading? That’s the only way I could rationalize it apparently changing with Cesium versions. To my knowledge, we haven’t changed anything about the way we render tilesets, so this shouldn’t have worsened over time. :thinking:

Either way, this seems like an artifact of the models themselves. I’m not sure we can do much about it because it’s Google’s data. But if you’d like, you can reach out to Google Maps Platform support and report this to them. Let me know if you have any followup concerns or questions!

Hi again Janine!

The version number for me is v.2.4.0

I think I need to clarify a bit here, it seems we are talking a bit past each other on the issues, I am not talking about the hole/gap in the mesh, this is just me using the cartographic polygon spline to cut a way a building.

What I am talking about is the small white pixels that flicker on the mesh.
It’s not the easiest to showcase on an image as you can’t see the flickering happen, but it’s all these small white pixels blinking on the mesh/material.

You will most likely have to view the image in full screen to get a good view of the problem. This does also not seem to be an issues just here but all over. I have also uploaded a short youtube video here showcasing the issue in motion:

I hope this helps, and thanks again in advance! :slight_smile:

Hi @MetaMagnus,

I’m so sorry about the misunderstanding. Because I didn’t expand those images, I genuinely thought it was dust on my computer screen, and the only bright spots I could see were the gaps in the tiles. :sweat_smile:

I found the source of the real issue. It has to do with the “DitherFade” material layer in the default Cesium material, which is associated with LOD transitions. I don’t know if you’re using LOD transitions for your use case, but you can remove this effect if you aren’t by doing the following:

  1. In the Content Browser, go to Plugins > Cesium for Unreal Content > Materials > Instances
  2. Copy MI_CesiumThreeOverlaysAndClipping into your project. You might want to rename it so you can distinguish it from the default material in the plugin.
  3. Open it and delete the material layer labeled “DitherFade”.
  4. Save, then assign this in the Material slot of the tileset.

This will make the flickering go away. Unfortunately, I do see this effect even with Enable LOD Transitions set to true. It seems like something goes wrong when there isn’t an LOD to transition to. I’ve written a Github issue so we can look deeper.

I hope this workaround is sufficient for now! Please let us know if there’s anything else I missed, or any concerns or questions. Thank you for reporting this issue :smile:

1 Like

Thanks for all the help and for creating a Github report on this!

Yes this fixed my issues! (just a note for someone else doing this, there are two different materials with the same name in the folder, make a copy of both if your unsure).

Thanks again for the quick help, If I find a smart solution on my end I will post it here. Again thanks! :slight_smile:

1 Like