Camera behavior after update to version 1.70

The new underground features are amazing :tada: Thanks!

But I have a question concerning the new camera behavior, especially underground.
Above the earth’s surface, clicking on the mouse wheel always rotates the camera around the center of the current view. This is the expected behavior.

If the camera is underground, there is now only a small area above the camera (= the “upper part” of the viewer container), where the camera rotates around the center of the current view. If you perform this action at a more distant location, the camera rotates only around itself. In versions before 1.70 was the area where you could rotate the camera around a central point much larger.
Is there any way to restore this behavior?
Is this dependent on the new near and far values of undergroundColorAlphaByDistance?

I can reproduce this behavior on my local installation of 1.69 and 1.70 as well as all new underground related sandcastles.

Thanks @mholthausen! And thank you for helping us with all your early testing on this!

I think I am able to reproduce the issue you’re seeing, starting with this view below the ground in this modified Sandcastle.

Click and drag with mouse wheel in the area marked “1” here seems to rotate from that point, and click and drag anywhere below (like in area marked “2”) seems to rotate the camera around itself:

I think this is to prevent the camera from picking a very far away point and moving too far accidentally. @sean_lilley can you confirm that this behavior is intentional?

1 Like

Yeah, that’s exactly right. The distance can be increased but it’s not part of the public API at the moment.

var cameraController = viewer.scene.screenSpaceCameraController;
cameraController._maximumUndergroundPickDistance = 20000.0; // default is 10000.0

I have modified this sandcastle a little bit, with the settings of the viewer, which are used in our case and set ._maximumUndergroundPickDistance to 80000.0
Unfortunately, I can’t restore the old (<1.70) camera behavior with this setting.
The area marked as “1” in the screenshot above is slightly extended by modifying this setting, but as soon as the camera is just a little bit deeper in the space of the earth’s interior, the camera turns around itself again when clicking the mouse wheel, like described for area “2”.

Is there no way to activate the previous camera behavior? This worked fine and behaved like the camera above the earth’s surface.