Camera not familiar

How to prevent cameras from entering the ground?
When loading data from a city, the camera operation is slow. Of course, I can adjust the step speed by checking the document, but it’s easy to fly out of the scene
The current control of Cesium for UE, hasn’t the camera added collisions? It’s easy to penetrate now
Loading an indoor 3D tile data, the current indoor operation is very inflexible. Am I using the wrong method? Do you have any good suggestions? Thank you

Assuming that your data is loaded with the “Create Physics Meshes” option enabled, the DynamicPawn should collide with your data. Perhaps the camera was moving fast, and the tiles it would have collided with were still loading?

In city areas, the camera will move at inconsistent speeds because it dynamically adjusts its speed based on its height above the data. This is to make the camera faster when it’s higher above the Earth, so that it’s not extremely slow to move at high altitudes. Unfortunately, this means it behaves erratically when you’re in cityscapes, because the height under the camera changes rapidly. You can disable the dynamic speed behavior by pressing G on the keyboard.

You can open the DynamicPawn’s blueprint to find more details about the DynamicPawn’s controls.