can't load cesium on chromium based browser

Hi,

I’m having troubles in trying to load the simple helloworld demo:

https://cesiumjs.org/Cesium/Apps/HelloWorld.html

On a clean OS X installation with the latest chrome browser installed (MacBook Pro 15 late 2011)

In Crhome, to be able to have WebGL running, which seems to be off by default, I had to enable the flag:

WebGL 2.0 Mac, Windows, Linux, Chrome OS, Android
Allow web applications to access WebGL 2.0. #enable-es3-apis

And then I also had to:

Override software rendering list Mac, Windows, Linux, Chrome OS, Android
Overrides the built-in software rendering list and enables GPU-acceleration on unsupported system configurations. #ignore-gpu-blacklist

However … now the demo page load (no webgl errors) but it gives me a blank background instead of the cesium globe

No logs in the JS console. while this is what I have for chrome://gpu/ [1]

On the same laptop,

I tried also with Safari, Opera and Firefox.

on Opera I got the same white screen as with Chrome

while with Safari and Firefox I had no problems in loading the demo … have you any clue on what is wrong? It seems to me something related to the chromium framework (which opera and chrome are based on) In the past with the same laptop I had no problem with chrome and cesium. Is this introduced by a recent Cesium release ?

Thanks fr any advice,

Massimo.

[1] https://gist.github.com/anonymous/6e8a90cd6d160d07c10556e82318e4f3

Hello Massimo,

I haven’t seen this issue with Chrome. You shouldn’t have to enable anything, Cesium uses WebGL 1.0 which is enabled on Chrome by default. What version of Chrome are you using?

What happens when you click ‘Tap to Interact’ on our home page? http://cesiumjs.org/

If WebGL is being blocked for some reason, that page should show an error message that WebGL is not supported.

Best,

Hannah

Thanks Hannah,
It is definitely something wrong on my OS. I tested the same code on linux and everything works as expected.

I’ll try to investigate and report back here if any finding

… for now the only clue is this segfault log [1] which is given from my phat app that loads a chromium webengine view that point to something broken about chrome

“Crashed Thread: 17 Chrome_IOThread"

[1] https://gist.github.com/epifanio/49c4cbd51a5e9bb47cf4d0186cca837b

Hi Massimo
I have the same problem, maybe even stranger.
Using OS X 10.9.5 I can run Hello World in Safari (9.1.3) successfully but when I run an app that uses Cesium I just get a black page with a slightly less black rectangle in one corner.
If I try running Hello World in Chrome, I get the bottom strip OK but just a white screen with no 'world' showing.
Running the same app I get a white square on top of the map which shows around the edges of the square.
Other people run the app with my data with no problems.
What is going on?
James

I’ve heard reports of this happening from users of my Cesium-based application, but so far haven’t been able to figure out what causes it. My best guess is it’s a Chrome extension (ad blocker or antivirus maybe) that is breaking something. Can you try running in an incognito window and see if it happens there too? If you have some kind of antivirus/firewall that might be mucking with web pages even in incognito mode (e.g. via a proxy), it could be worth trying with that disabled, too, if you can.

Hi Kevin
Same thing happens in an incognito window and I’m not running any ad blockers.

So still scratching my head.

James

What about an antivirus or Internet security product of some sort? Are you using anything like that?

Same thing happens with me too. It's annoying because firefox works but it slower.