The current version of chrome crashes while loading cesium

Hey guys, just a heads up that Chrome 23.0.1271.64 m is crashing with the “Aw, Snap!” message loading cesium. You can check this out by hitting the sandbox link or even the new website at

It works fine though on the older samples which is weird. Maybe there is a chrome webworker bug? We had to switch to using Chrome Canary to keep working. Have you guys noticed this or think it’s even a big issue?

Hi Jonah,

I’m running the same version of Chrome without problem on Windows 7 with an AMD card. What OS are you on? Windows, right?

Have you tried restarting Chrome (including all tabs)? Firefox works OK for you I assume?



That’s right Patrick, this is happening for all of us on windows 7 64-bit. Browser restart and machine reboot do not help. We even tried a fresh install of chrome. This chrome version works fine though on windows 7 32-bit.

Can you try running Chrome in “incognito mode” as a shot in the dark. This could be a Chrome bug we’ve run into before. I’ll also add that is pretty out of date; so it’s possible there’s an issue that we can fix just by updating it.

No luck with incognito mode. The old samples work fine. The new site crashes though. My belief that it is a webworker bug seems to be correct because this simple webworkers example crashes me.

I noticed that Google Calendar crashes the same way and did some searching on that. It's a problem with Microsoft's Enhanced Mitigation Experience Toolkit (EMET) software. It can be fixed by disabling SEHOP for Chrome.

1. Open EMET using windows search
2. Click "Configure System" and change SEHOP to "Application Opt Out"
3. Click Configure Apps and add Chrome. Uncheck SEHOP.

Anyone ever figure this out? Cesium stills seems to be crashing on the latest version of Chrome (OS: Windows 7 64 bit).

See my comment above for a work-around. This is a Chrome/Windows EMET bug, not a Cesium bug. I believe there are some pre-release versions of Chrome that don't have this problem so hopefully it'll be fixed soon.

Ahh, I see - yeah it works perfectly fine in Chrome Canary - Awesome! Thanks!