Cesium 1.31 WebGL Error

Hi Cesium Community,

I ran into a very strange error today after upgrading to 1.31 from 1.23. I’m loading a somewhat large polygon dataset (2800 polygons) from a json file. Cesium version 1.23 loads the data with no errors while Cesium 1.31 renders the polygons and freezes the browser, throwing the WebGL error in the attached image. Besides upgrading Cesium versions, I made no other changes to the application. Cesium 1.31 works fine when I load a smaller polygon dataset (100 polygons). Any ideas about this issue? I think the error happens with version 1.30 as well, but I haven’t been able to check which versions work and which ones don’t. Thank you all for your help, Cesium has a great community and is a great framework!



Hello Justin,

Have you tried clearing your cache/cookies? Sometimes that can cause unexpected side effects when switching between versions of Cesium.



Hi Hanna,

Thanks for the quick response. I just cleared my Chrome cache and cookies and unfortunately I still have the same WebGL problem. Did the same in Safari, and I don’t get the WebGL error but the browser just freezes. It’s strange that the browser crashes after rendering the 2800 polygons. Again, no problems with Cesium version 1.23



Thanks Justin. We’ve had a few other users say that they’ve seen decreased performance starting in 1.30. I’ll ask around to see if someone knows what might have changed