Chrome crash loading a GeoJson data source

Hi Folks,

My Chrome browser (Version 57.0.2987.133 (64-bit), MacOS 10.12.2, MacBook 8GB, Intel HD Graphics 515 1536 MB) is crashing when I try to load a moderate size GeoJson data source.

The error is:

An error occurred while rendering. Rendering has stopped.

TypeError: Failed to execute ‘shaderSource’ on ‘WebGLRenderingContext’: parameter 1 is not of type ‘WebGLShader’.

TypeError: Failed to execute ‘shaderSource’ on ‘WebGLRenderingContext’: parameter 1 is not of type ‘WebGLShader’.

The console says:

WebGL: CONTEXT_LOST_WEBGL: loseContext: context lost.

It actually works on Firefox 52.0.2 (64-bit) on the same machine, and it also works on Chrome on an iMac desktop with a lot more memory. Which leads me to believe this is a memory issue. BTW, after I hit this error, I have to restart Chrome, otherwise all other Cesium apps start crashing – which means Cesium needs to deal with this problem more gracefully – please\ let me know if you want me to submit an issue to the Github repo.

The GeoJson data source has about 6,600 features, about 5,000 polygons and about 86,000 coordinates. Is this size unreasonable for Cesium with this hardware? Do you have any suggestions? Should I start using 3D Tiles for this?

Here is a link to the example that causes the crash, if it helps to reproduce the problem:

Any help is greatly appreciated.

Thank you very much,


Ah, I forgot. Cesium version 1.32.



Hey Ricardo,

We tried your example and it worked for us – did you try clearing your cache? Sometimes that causes weird side effects when switching between Cesium versions.


  • Rachel

Well, it works for me too, but not on smaller machines. That is why I think it has something to do with memory. But Cesium should be more graceful about it.

Any recommendations to work around this problem?



Have you run diagnostics on the smaller machines? I'd rule out the hardware compatibility issues unique to your minimum hardware, if the code runs on more robust hardware, before assuming its a cesium core software issue. I hope you find the cause of the render crash.