Cesium Flickering OSX and Chrome Beta 69.0.3497.57

Experiencing a problem where Cesium is flickering quickly. This issue happens on the Cesium Sandcastle and on other apps. Flickering happens regardless of user/mouse input.

Problem exists on the latest Chrome Beta 69.0.3497.57. Does not happen on Safari. Issue can be replicated on Cesium Sandcastle.

Operating system OSX High Sierra version 10.13.6 (17G65) Intel Iris Graphics 6100 1536 MB.

Can't replicate the problem on any of the examples from http://webglsamples.org/


Thanks for reporting this Murray.

I’m having some trouble recreating this. Have you checked if it happens on Firefox too? Also, is it that the whole screen flickers or certain elements (like in this example where the billboards flicker for example https://github.com/AnalyticalGraphicsInc/cesium/pull/6802#issuecomment-406071049 ) ?

Any additional info to help us pin this down would be very much appreciated!

I get this too. I'm on a 2015 13" MBP, so no dedicated graphics. Latest Chrome, OS and Cesium. I've tried numerous Chrome versions and have now been through a few OS and Cesium updates.

It's just the Cesium map element. When the screen flickers it's just the map layer disappearing, you can see space and stars for fractions of a second before the map returns.


Thanks for the reply Omar.

Issue does not happen on Firefox. It's the whole screen that flickers. As the above poster mentioned, it appears to be the map layer disappearing.

Made a screen grab of the flickering on Cesium Sandcastle

Same here: https://imgur.com/a/8x2ChkR

Thanks for recording these. I’m surprised this bug took so long to surface. You said you’ve been through a couple Cesium updates, has it been happening for all of them? Could you check a few versions back to see if it was something we’ve added recently?

The easiest way to do that would be to download the zip file from an older release from here (https://github.com/AnalyticalGraphicsInc/cesium/releases) and run the “Hello World” example or Sandcastle locally with the instructions here (https://cesiumjs.org/downloads/#quick-start-guide). Don’t feel like you have to try every release but perhaps space them out so we can try to see how far back this goes.

So far it sounds like it’s a Chrome on Mac issue and it’s only specific to the imagery. I wonder if it happens with all imagery. Does it happen with the Blue Marble as well? What about this one which uses imagery built into Cesium? And lastly maybe try one with multiple imagery layers, do they all flicker in the same way?

I’m also curious what it looks like with Terrain turned on.

I wonder if it might be a networking issue. Can you look at the network tab while it flickers? You should see activity as you move/zoom in as it requests map tiles, but there shouldn’t be any requests if you’re not moving or anything.

I know that’s a lot of things to check, but trying any of those will help us a lot in narrowing this down especially since we haven’t been able to reproduce it so far.

Thanks for the suggestions Omar.

I tried all the imagery layers/terrain that you suggested and it still flickers. With Terrain on it flashes black with yellow and red 'on top.' I also ran 1.41 on my local machine and the issue is still there. Without the globe there is no flickering.

No network requests are being made while the globe flickers

One thing I did try is rolling back chrome to v60, that seems to stop the problem. Obviously not an ideal solution though.




This example also fails quite spectacularly on some of our MBP's at work


Thanks for finding this Murray! It might be worth posting there too to let them know it’s still an issue/that more people are experiencing it.