Cesium raster overlay problem

Hi Cesium Team,
I‘ve updated cesium for unreal to the latest version(v2.3.0), and found some issues when adding Raster Overlay to CesiumWorldTerrain. The following is my report.
I tried to mount more Overlays in the CesiumWorldTerrain. First I added a Material Layer called “Overlay3” in MI_CesiumThreeOverlaysAndClipping, and then used MI_CesiumThreeOverlaysAndClipping as the Rendering-Material of CesiumWorldTerrain. After that, I tried to mount 4 Raster Overlays in the CesiumWorldTerrain, but found that the Raster Overlays were staggered and could not be displayed properly. Please refer to the following gifs for details.
Looking forward to your reply. Thanks.

Hi @Fastidium ! Welcome to the community, and thanks for your patience.

I’m afraid your gifs aren’t loading for me, so this is a shot in the dark. But my initial guess is that the raster overlays don’t have their “Material Layer Key” configured properly. As an example, this is how it will appear on a Cesium ion Raster Overlay.

This key controls which layer in the material instance that an overlay is assigned to. For instance, these are the material layers in MI_CesiumThreeOverlaysAndClipping, the default material used for Cesium3DTileset:

This layer key is used to distinguish the raster overlays from each other in the material. Each raster overlay will upload its textures to the material layer it is assigned to. When multiple raster overlays reference the same “Material Layer Key”, though, this can lead to some unexpected results.

So I would double-check that each overlay has a different material layer key first. The order does matter; for instance, the key “Overlay2” appears above “Overlay1”, so the raster overlay with key “Overlay2” will be used after the first one.

If this doesn’t resolve your issue, though, please respond with more details. In particular, we’d need you to share:

  • the images that you were previously sharing.
  • screenshots of the raster overlay components attached to the tileset (so we can see each one’s properties).
  • a screenshot of the material your tileset is using.

Thank you!

Hi, I hope I could help. The RasterOverlay Component has such propety as “Specify Zoom Levels” with "Mininum Level "and “Maxinum Level” beneath it. Check “Specify zoom levels” , and fill in the values of the "Mininum level "and “Maxinum level” related to the Map. So that when you zoom in , the map won’t be blank if it has no correspond level.

Hi, @janine ! Thanks for your patient reply.
I’ m sorry about those low resolution gifs. I have taken some clearer screenshots of the raster overlay components and the used material (MI_CesiumThreeOverlaysAndClipping) as shown in the following.

As can be seen in these screenshots, a new material layer called “overlay3” was added in the used material, and 4 raster components were attached to the CesiumWorldTerrain tileset. For each raster component, the material layer key was set to “overlay1”-“overlay3” respectively. The Viewports in the screenshots show that the Raster Overlays were staggered. However, when the raster overlay that is bound to “overlay3” is removed, the tileset can be displayed normally.
Looking forward to your reply. Thanks!

Hi, @pjiang9 ! Thanks for your reply.
I failed to find “Specify Zoom Levels” in the RasterOverlay Component. Could you show some screenshots about your setting interface? Thanks!