Correct setup to allow interpolation of CZML data-passed dynamically

Hi. I am generating orbital data from Matlab, piping that data to the node server, where it is formatted and sent to a client (Cesium-based) app.
The orbit data (position and velocity) is generated for every second. I transmit a packet containing the timestamped data every 10 samples. The CZML packet is of the following form:
var json = {
    "id": "sat1",
    "point": {
        "pixelSize": 12,
            "rgba": [255,0,0,255]
         "position": {
             "epoch": "2015-04-22T11:50:25Z",
       "referenceFrame": "INERTIAL",
       "cartesianVelocity": response.position,
             "interpolationAlgorithm": "LINEAR",
             "interpolationDegree": 1,
             "previousTime": -1.0,
             "nextTime": 10.0
response.position in "cartesianVelocity" is an array with the format [time,position_x,position_y,position_z,velocity_x,velocity_y,velocity_z,...] (for 10 samples).
When data is received on the client app it is passed to:
   var response = JSON.parse(msg);

Using this framework I am able to pass generated data into the cesium library and view the position of the satellite. The problem I have is that the rendering does not interpolate for time instances between supplied data (between the 1 second gap). I have tried the other available interpolation algorithms and orders but it does not smooth the transition between data points. Is there some something fundamental that I am missing?


After further experimentation I have found that larger sampling times (of the raw data) result in smoother rendering (interpolation does occur). I also noted an mistake in my last code-I believe the following correction in the packet is required (doesn't have an affect on results though):
  "previousTime": response.position[0] - 1.0,
  "nextTime": response.position[0] + 10.0
Can someone point me to the source code that calls the interpolation, or how to control the resolution of the main ticker responsible for the graphics update? I need to display the attitude of a satellite that may be spinning at a high rate (hence my requirement for the resolution),


nextTime/PreviousTime are currently unused, so you can leave them out entirely if you want.

Are you viewing the data in real-time? If the samples you are streaming down are always slightly behind the computer time, and you are animating at “now” in Cesium, you won’t see interpolation because the default interpolation settings are not to extrapolate. You can turn on extrapolation with the forwardExtrapolationType/forwardExtrapolationDuration properties. If you are viewing in simulated time and the this is still happening, can you share a small bug complete CZML snippet that can be loaded into Cesium to demonstrate the problem. At face value there’s nothing wrong with the CZML you’ve shared so far.