D is not a constructor


I have been using Cesium Ion a bit today and uploaded a number of assets. I still have plenty of space and the assets upload without error and the tile process initializes and runs to apparent completion (the final preview of the asset look correct). However, suddenly when I try to adjust the tileset location, I get the following error: “D is not a constructor”.

This error doesn’t tell me much so I need a bit of help. I have tried testing with a tileset that previously worked (same error now). I have tried shutting my browser and restarting. I have tried shutting other programs such as my GIS and Unreal Editor. I have logged out and back in but I don’t seem to be able to get past this one error. I have tried uploading a completely different file type.

Is this a problem at my end or with Cesium Ion (and is there anything else I can do)?

Many thanks

1 Like

Hi, I have the same problem, I’m using Unreal and today I started to get “D is not a constructor” and cannot adjust the tileset location, it was working few hours ago.



I apologize that you are seeing this error. Would you be able to provide me with a little more information so that I can better understand the error you are seeing?

Are you seeing the error show up on Cesium ion or on Cesium for Unreal? Can you adjust the tileset location on ion?
Could you also provide me with the asset id that seems to be having an issue, I can take a deeper look at the asset itself to find out what is going on.


Hi Ankit,

The error has now gone away overnight (UK). I was seeing the error when I try to adjust the location in Cesium Ion. It wasn’t a specific asset that was the issue but all assets, even those that had been uploaded previously and had their locations adjusted without any problem. When I went back (as a test) to try a readjust their locations, I got the same error. So, once the error appeared, no asset whatsoever could have its position adjusted whether new or existing.

As I say, the error has gone away and the asset whose location I was trying to adjust has been located without any error this morning (UK time).

I hope that helps