Globe Materials not working w/ globe.enableLighting=false

1. A concise explanation of the problem you're experiencing.

Hello! I noticed in the release notes for 1.41 that issue #6042 was resolved.(https://github.com/AnalyticalGraphicsInc/cesium/issues/6042)

However, I am still experiencing issue with Globe Materials and the enableLighting flag.
I do not want to enable lighting, but I would love to make use of this awesome new feature!
Below are some screenshots, but basically if lighting is not enabled the material only shows up when the camera is zoomed out. As you zoom further in the material starts to disappear.

I am using the standard stk-terrain dataset, if that's relevant.

2. A minimal code example. If you've found a bug, this helps us reproduce and repair it.

viewer.scene.globe.enableLighting = true;

viewer.scene.globe.enableLighting = false;

3. Context. Why do you need to do this? We might know a better way to accomplish your goal.

Being able to show slope angles is a HUGE win for me, however I need it to work even when the user is zoomed in close up on the terrain

4. The Cesium version you're using, your operating system and browser.
Cesium 1.42.1
OSX 10.13.2
Chrome 63.0.3239.132

That’s definitely strange behavior. Setting enableLighting to false seems to work in the Sandcastle demo so maybe there’s something about your app that is triggering that bug. If you are able to create a self-contained example that exposes the problem that would be really helpful!