Google photorealistic 3d tiles missing

Hello, I have the “google photorealistic 3d tiles” option missing.
Do you know why?
I attach a screen of my situation
thank you

Have you tried “Blank 3D Tiles Tileset” at the top?

Yes, I added the 3d tiles tileset, but the google option doesn’t appear

Try to create a new Token, what engine version are you using?

I added the token but nothing changes. I’m using 5.3
Now I try to test with different ue versione

Try Update your token on Cesium ion

These are the screens of my token updates following yours. The google 3d option still doesn’t appear, and also the details panel of my cesium 3d tileset looks different than yours.
I tried in unreal 5.1 and it works At this point I’ll work there. I don’t need 5.3 features for this project.
Thank you for the help


Can you share what version of Cesium for Unreal you’re using? The Google Photorealistic 3D Tiles option is a relatively recent addition, so you may be using an older version that doesn’t have it.

Cesium is ok, because I installed it in unreal 5.3 and unreal 5.1, but in 5.1 it works. I even tried to reinstall the plugin.

The Google Photorealistic 3D Tiles option was added to the Quick Add panel in v1.31.2 and v2.0.0. If you have any version older than these, it won’t exist and you need to upgrade. Go to Edit->Plugins->Geospatial to check your plugin version, and upgrade it from the Unreal Engine Marketplace.

Now it works! Thank you.
Do you know if it is possible to make the 3d from google earth (buildings etc) to cast shadows?

In the Cesium3DTileset’s details, find and tick the checkbox next to the “Ignore KHR_materials_unlit” setting.