Hiding UE5 'Landscape' element

I’m having an issue where my map has a default Landscape element that I can’t seem to turn off in the ‘Play’ environment, you can see the issue in this screenshot, the Dynamic Pawn preview shows the floating ‘Landscape’ element.

In the editor mode I can:

  • Hide it using ‘Show’ button in the editor window and unclicking ‘Landscape’, or Alt + L keyboard shortcut.
  • Set visibility to ‘Hide Selected’ in the Outliner tab

For game mode I’ve tried setting the following details on the ‘Landscape’:

  • Actor Hidden In Game = ticked
  • Is Editor Only Actor = ticked

The ‘Game’ mode will also crash removing the CesiumWorldTerrain and other elements if I attempt to travel too far from the spawning location.