How can I see a complete rendered Earth in the camera view?

At scene window, I can set the Far of Clipping Planes very large like this.


Then I can see the whole rendering earth by pulling the angle of view very high, although there is still a part of the content that has not been rendered.

But if I want to do this in the Game window, it is impossible. When I zoomed the camera to a higher angle, I could still see the parts that were rendered, but when I zoomed to a point where I could see the whole earth, all the parts wouldn’t be rendered.

You need to increase the near plane. Unity seems to have a hard limit on the far:near ratio of 100,000. So if your near plane is 0.03, Unity will ignore any far plane value greater than 3,000 (0.03 times 100000). It will silently render as if the far plane is set to 3,000. It’s rather silly and I’ve posted to the Unity forum about it (, but haven’t received an answer yet.

I found something. My program works in HDRP. In URP, adjusting the near clipping is effective, but not in HDRP. In HDRP, if you set your Sky type to Physically based sky, you will not be able to see the whole earth, and most of it is covered by dark shadow.

If you set the Sky type to HDRI Sky, all problems seem to be solved.I guess it may be related to Unity’s lighting system.

In HDRP, it is not necessary to set the value of Near very large. I can still see the whole earth by setting it to 0.03

1 Like

@nnn Good finding. Thanks for sharing!