how to turn off day/night light effect?

1. A concise explanation of the problem you’re experiencing.

I try to turn off day/night effect by using viewer.scene.globe.enableLighting=false; however, this doesn’t work (see the attached .gif animation). I also tried the option “shadows: Cesium.ShadowMode.DISABLED” in Cesium.Primitive and no luck as well.

Anybody can light me the possible reason? Thanks a lot!

2. A minimal code example. If you’ve found a bug, this helps us reproduce and repair it.

currentImgLayer = viewer.scene.primitives.add(new Cesium.Primitive({

geometryInstances: new Cesium.GeometryInstance({

geometry: new Cesium.RectangleGeometry({

rectangle: Cesium.Rectangle.fromDegrees(-180,-90,180,90),

height: Number(imgAltitude)1000altFactor,

vertexFormat: Cesium.EllipsoidSurfaceAppearance.VERTEX_FORMAT



appearance : new Cesium.EllipsoidSurfaceAppearance({

//aboveGround : true,

material: new Cesium.Material({

fabric : {

type : ‘Image’,

uniforms : {

image : eImagePath+’/30/ed_2018-01-01T00_30.png’





shadows: Cesium.ShadowMode.DISABLED,

show : true


3. Context. Why do you need to do this? We might know a better way to accomplish your goal.

4. The Cesium version you’re using, your operating system and browser.

Cesium: 1.53 and 1.54.


The Gif you posted doesn’t seem to be animated. Can you try posting a Sandcastle ( example and link to it here?

If you turn off both lighting and showGroundAtmosphere like in this example it might be do what you need:

Unless you’re referring to a different effect. So if you can repost the gif maybe on imgur or ideally a Sandcastle example that’d help.

I converted gif to mp4 due to my gif doesn’t work.

Untitled-1.mp4 (46.7 KB)

Set “scene.globe.showGroundAtmosphere = false” does not work neither.

Is the moving green on that map images created from the material in your code sample? What do the images look like? Do they have transparency?

It sounds like your issue might be the blending options between these materials as opposed to lighting on the globe.


I implement a time dynamic imagery animation by using a set of time series images. I have turned off sun light with option " viewer.scene.globe.enableLighting=false" and “shadow=false”, why does the blending matter if the materials as opposed to no lighting?


Can you explain how you expect your imagery to look like?