3DTiles Shadows not turning off?

1. A concise explanation of the problem you’re experiencing.

In the following sandcastle example I tried to disable shadows in the viewer and on the 3DTiles itself but shadows are still appearing as you scrub through time. Am I missing something?

2. A minimal code example. If you’ve found a bug, this helps us reproduce and repair it.

3. Context. Why do you need to do this? We might know a better way to accomplish your goal.

I was trying to turn shadows off on my own 3DTiles set which wasn’t working but I noticed that it doesn’t work in the sandcastle example of NYC either.

4. The Cesium version you’re using, your operating system and browser.

1.39 / Windows 10 / Version 62.0.3202.89 (Official Build) (64-bit)

Disabling shadows on the 3DTile seems to turn off the casting but receiving still seems to work.

Hey Kevin,

Shadows are off by default, but model shading is still present and will change as the sun direction changes. This isn’t actually controllable through the API because it is built in to the shaders packaged with the tileset, and we don’t override them.

If you’re seeing actual shadows that buildings cast onto the ground, that definitely shouldn’t be happening.

Thanks for the explanation! I was misunderstanding what shadows referred to.