Inaccurate Set Georeference Origin does not respect a scaled tileset after execution

Hey all, can anyone confirm this? After the last update I am unable to get collision with the tileset mesh AFTER I run Inaccurate Set Georeference Origin Lat Long Height. This happens when the tileset is scaled – it works correctly if the tileset has a default scale of 1.0 on the Earth tileset, but if I run it on a tileset with a different scaling value, collision is gone after I update the Georeference.


Hey @mahalobay,

Are you unable to get collision at all from the tileset? Is there a chance that the collision meshes are appearing at the unscaled location?

Additionally, how are you using collision in your project? E.G. line traces, a character controller, something else?

This is definitely an odd issue, thanks for bringing it to our attention.

Hey Alex, I have a DM thread on this with Kevin Ring atm, you can check in with him about it. We’ve traced it back to between CesiumForUnreal-427-v1.14.0-ue4 (which works) and CesiumForUnreal-427-v1.15.1-ue4 (which does not).

I’m doing physics collision (vehicle wheels) as well as line traces and both are affected. When the level is initialized, it works correct, but when I change the geo reference during runtime, it no longer works.

Collision meshes look intact before and after, unfortunately…

I am currently rolled back to 14 so I can continue doing stuff, but if we figure out what the issue is I’ll update you as well :slight_smile: