Incorrect Lodding and Processing of Photogrammetry to Tilesets


I have been given some small 20mm photogrammetry tilesets to process into tilesets with Cesium Ion and integrate into an output for a client. The photogrammetry data is in fbx format with fbm associated files with the texture.

I have uploaded all this data to s3, imported to cesium ion and selected the option to create tileset. Everything worked fine, the data was transferred, the models were read and processed into a tileset.

However, the resultant tileset is not behaving like other tilesets I have in the library sourced from other data providers. It seems like the lods are not computed properly.

As you can see in the below preview in UE5, the outer data for the tileset is loaded when zoomed out far, as you get closer smaller tiles load in and when you get closer all the data exists. When all the data is loaded close up, the data is so heavy that the scene slows down and runs out of memory.

The exact same as above happens in Cesium js as well.

Does anyone know why the tileset would be processed like this, to me it doesn’t even seem like the source data was processed at all and it just gets loaded in in full detail at an arbitrary lod distance.

Perhaps the source files need to be converted from fbx + fbm to obj or something? Any help is appreciated.

Sorry you are having trouble with this dataset. In order to investigate this further we would need some additional information:

  • The asset id of the asset you are having trouble with
  • Temporary credentials (or permission to reuse the credentials you provided with the job) to download the source data from S3. You can send these to and reference this thread.
  • If known, what program created the source data



  • The asset ID is 2499431.
  • You have permission to resuse the credentials provided with the job.
  • It is unknown what program the source data came from.
  • The data is 20mm photogrammetry data from a couple of years ago. It was provided to us as fbx tiles.

I have tried a couple of things since making the original post.

  1. I went through the tiling process again but this time selected the “3D Capture / Reality Capture / Photogrammetry” data type. This process ended up failing with an error.
  2. I removed the original job, re-uploaded and processed the data without the .fbm folders just leaving the .fbx meshes and .jpg textures. This resulted in the same behavior as the original job.

My guess is since the issue is present in multiple attempts, the source data is the problem.

Thank you for that additional information. I have created an issue for our team to investigate this further. we will keep you posted on any updates.