Installing Cesium for Unity always fails

Hello, I would like to ask why the Cesium for Unity can not be installed and the red window always pops up? I followed the official tutorial。

The Cesium for Unity package is hosted on Most likely, something on your network is blocking access to it.

I installed Cesium for Unity package but seemed to have more problems.

I’m assuming that you downloaded the tarball from Github and are trying to add it to Unity, right? Cann you remove the package as well as the scoped registry, and try readding the package using only the tarball?

Hi, I am facing the same issue. While trying to import the Cesium Unity package through scoped registry, I get SSL certifcate error - “[Package Manager Window] Cannot perform upm operation: self signed certificate in certificate chain [UpmError_NotFound]. UnityEditor.EditorApplication:Internal_CallUpdateFunctions ()” .

I tried downloading the zip package from here " GitHub - CesiumGS/cesium-unity: Bringing the 3D geospatial ecosystem to Unity". I imported that in project. And see lot of compilation errors.

Kindly help!

That’s pretty suspicious that you’re getting SSL errors. Assuming you’re using the correct URL for the Cesium package registry (, all certificates should be valid and none should be self-signed. You should probably contact your system adminstrator, as you may be the victim of a man-in-the-middle attack.

How did you download the package from github and what did you do with it? Downloading a ZIP of the source repo won’t do what you need. The correct approach is to go to the releases page:

And download the .tgz file. And then install that using the Unity Package Manager.

Thanks for your response. Yes, downloading .tgz file worked. Also, SSL errors were due to organization firewall. Got it resolved now. It works with scope registry as well now. Thanks.