Latest update crash

Just got update for cesium and its crashing all the time please fix asap. Its completely useless atm. There is no problem in editor but in game and in standalone it crashes.

Sorry you’re having trouble @Ben1, but you’re going to have to give us more information before we can help you. Such as:

  1. Confirm which version of Cesium for Unreal you’re using by going to Edit → Plugins → Geospatial.
  2. What version of Unreal Engine itself are you using?
  3. What platform are you on?
  4. Does the Cesium for Unreal Samples project have the same problem, or is it only your own project? You can install this project from the Epic Launcher.
  5. If it’s only your own project, what other plugins do you have active?
  6. Does downgrading back to the old Cesium for Unreal version fix the problem? You can get old versions here: Releases · CesiumGS/cesium-unreal · GitHub
  7. What tileset are you using when it crashes?

According to your call stack, you’re crashing on this line of code (assuming you’re using v1.30.0):

I can’t see any good reason that line would crash, and it certainly doesn’t in a Windows Shipping build here, so we’re going to need your help to reproduce before we can fix it.

  1. 1.30.0
  2. UE 5.2
  3. Windows 11
  4. Yes it has the same problem

  5. I have to do try this later…
  6. Everything is default.

I had everything working fine yesterday untill today i updated cesium from epic game launcher and now its not working anymore. Here is crash report from cesium samples.

Really strange. I don’t have any trouble running a Shipping configuration build of the Cesium for Unreal Samples project. Windows 11, UE 5.2, plugin installed from the Epic Marketplace.

It’s a long shot, but maybe something was corrupted in the request cache? Delete cesium-request-cache.sqlite* in C:\Users\[your username]\AppData\Local\UnrealEngine\5.2.

Or maybe it’s worth trying an uninstall / reinstall of the plugin? Can you try a different computer and see if it happens there, too?

Would you mind walking me through the steps you’re following in excruciating detail so I can make sure I’m doing the same thing? Starting with installing the Samples project from the Epic Launcher.

I tested with another computer with clean install and after i hit play in sample demo i get the same crash report in 10s - 1minute after launch. It sometimes take longer and sometimes shorter to crash. Tomorrow i will test with older versions.

CONSTANT CRASHES INDEED! do you have a QA? dont worry ill post the log on my next one.

in editor…after loading the level…flying around for like 2 seconds…hangs…ue5.2.1 crashes.

it crashes in editor even if no tiles are visible in the viewport.
cesium 5.2.0

pretty angry that such a version can be posted on the marketplace.

First of all, I’m really sorry you’re both having trouble.

But second, you may want to save your anger for someone who isn’t working on the weekend trying to help track down a problem with a free and open source plugin. Instead of anger, please provide as much information as you can to help me diagnose the problem. If it’s holding up your work in the meantime, it’s easy to downgrade to a previous version until this is resolved. All releases are here: Releases · CesiumGS/cesium-unreal · GitHub

I was eventually able to see a crash by building a shipping game with CWT + Bing and flying around for quite awhile, probably over 5 minutes. If you know a way to make it crash in “like 2 seconds”, please provide as much information as you can. Which tilesets? Was this the editor viewport, play in editor, a built game, etc? The faster I can reproduce it, the faster I’ll be able to solve it. But I’m working on it, in any case.

I believe I’ve found and fixed this bug. You can download a pre-release version with the fix here:
UE 5.0:
UE 5.1:
UE 5.2:

Uninstall the existing plugin using the Epic Launcher, and then extract the downloaded ZIP to C:\Program Files\Epic Games\UE_5.2\Engine\Plugins\Marketplace (or equivalent for your system and UE version).

More details about what was wrong are in the PR:

If all looks well, we’ll release an official 1.30.1 this weekend, but it probably won’t be available in the Unreal Marketplace until Epic is able to review and publish it this week.

Thanks for your patience!

your pre-release UE 5.2 seems to do the trick…i dont get crashes anymore!

thank you so much for your rapid reaction! wont be forgotten.
and sorry for bringing my bad mood into the public…im under pressure this weekend and worried that i have to bring bad news on monday but its looking fine now and i might be able to catch up.

again what an awsome reaction by CESIUM…<3 <3 <3

All good, mate. Thanks for trying out the pre-release and letting me know it solved the problem for you. I just published v1.30.1 with the fix to the Release page. It will take a little longer to hit the Unreal Marketplace. Apologies again for the regression!

Everything is working now. Thanks alot!

Btw is it possible to have cesium compatible for ue 4.23 version? Would be nice to use cesium with html5 projects as unreal only supports html5 in 4.23 version and below. You can use html5 in 4.27 if you compile the engine from another source but i dont know how to do that… Is it huge task to get cesium working in 4.23 version of unreal? and would it even work in html5 “game”?

Yes, it’s probably a lot of work to support UE 4.23, and even then it’s very unlikely the HTML5 support will just work. And even if you got all that working, you’d have invested all the time and energy in a version of UE (and a technique in general) that is no longer supported by Epic.

If you’re targetting the web, we highly recommend you use CesiumJS instead:

But it’s all open soruce, so go nuts if you feel like trying! The ue4-main branch contains the last version we released that supported UE4.27. Older versions in that branch worked on 4.26. We never supported any version older than that.