No globe secene could be imported to Omniverse

I have downloaded the lastest extension from github . According to Guide book , I used the default token to open the global scense .But there was nothing happen.

Hi @vigor_cao,

Sorry to see that you’re having issues. Would you mind confirming that you have selected the Cesium extension to autoload and that the Fabric Scene Delegate enabled?

To confirm that the extension is set to autoload, open up the Omniverse Extension manager and confirm that the autoload checkbox is checked. We use some custom plugins for USD which require the extension to load at launch of Create/Compose or Code.


For the Fabric Scene Delegate, you should see a dialog box on launch of any Kit application with the Cesium extension loaded like the one below:


By clicking “Yes,” it will enable the Fabric Scene Delegate and reload the stage. If you clicked, “No,” then you’ll need to open the Preferences, navigate to “Rendering” and check the “Enable Fabric delegate” checkbox. This will require you to reload the stage.

If neither of those suggestions help, please let us know.

Thanks a lot . I can open the scene. but I upload the special data, 3dtiles. I can see the web cesium ion. But I can’t import cesium for omniverse.

Hi @vigor_cao,

Can you ensure that you have the Cesium Georeference Origin to a value near your tileset? For instructions how to do so, please refer to the Quick Start Guide step 5, sub-steps 1, 2, and 3. You’ll need to set the Georeference Origin point to a latitude, longitude, and height that corresponds with what you provided when you uploaded your asset in Cesium ion.

Please let us know if this doesn’t solve your issue.

1 Like

@adam_morris Thanks a lot . I have done it