Object not configured to connect to Cesium ION. Error code 429

Everything was going swimmingly, I restarted Unreal and the Google Maps tiles do not load in any more. I just see Cesium Sky etc.

1 Like

The ion troubleshooting panel isn’t going to do anything because Photorealistic 3D Tiles are streamed through Google, not ion.

Can you wait ~10 minutes and try again? If the error for too many requests is showing up, then subsequent attempts to load the level in a short period of time probably won’t help.

1 Like

Ok. Thanks for the reply. I will get back to you. Many thanks

Waited, still no joy. I created a new API key and it’s working again now.

Any reason why this might be working now with a new API key? This is all new to me sorry.

I’m not sure what could have caused that behavior, honestly. If it’s anything from our end, maybe something with the sqlite cache got messed up? If you go to AppData/Local/UnrealEngine/(Version Number) you’ll see cesium-request-cache.sqlite files that you can delete, and that should recreate the cache.


Started to get some strange errors with the maps geometry, so I refreshed the tiles and now the maps data has disappeared again. I’m met with the same 429 error code as before.

RE AppData/Local/UnrealEngine/(Version Number)
No such directory exists on my machine. Is there anything I can give you to look at, to troubleshoot?

I’m met with this copying the error code into a web browser

How can I get around this, I assume this is google causing this issue.

It seems I’ve maxed out my quota on google cloud, a max 250,000 requests per day. Is there no way of increasing this? This would appear to be (to me at least) no way near enough for anyone working within the Architectural industry. Seems a bit silly you can just create a new API key and get another 250,000 requests, why don’t google just give you a couple of million if it’s that easy to get around?

Google considers this API to still be in an “experimental” state. I definitely encourage you to give them this feedback during the experimental period.

How long did you wait? I had my Unreal Project launched on Ndisplay on an Led volume and in the middle of my session all my buildings disappeared. I waited like 30 minutes and generated a new API key and nothing is working still.

It was working fine for like a day straight and now I get the same error code as you when I troubleshoot token

My output log is also giving me this error

LogCesium: Error: [2023-05-25 16:02:16.891] [error] [TilesetJsonLoader.cpp:810] Received status code 429 for tile content https://tile.googleapis.com/v1/3dtiles/datasets/CgA/files/UlRPVEYuYnVsa21ldGFkYXRhLnBsYW5ldG9pZD1lYXJ0aCxidWxrX21ldGFkYXRhX2Vwb2NoPTk0NyxwYXRoPSxjYWNoZV92ZXJzaW9uPTY.json?session=CIOk3MTypMq11wE&key=AIzaSyB4gFJWFzH-xTnBytq6Jd7zfCSNxRDp-5Q

I have passed on the feedback. I imagine this will be a recurring issue for many users.

It won’t refresh until the following day. I tried a new API key and that no longer works.

A workaround that seems to be working is to not close Unreal, or load a new project or level. Harder said than done.

I was thinking if it would help to lower the maps tiles LOD too? Maybe that will reduce the amount of requests so not to go over the daily quota too quickly?

that helped me - thx