Page crashes with downloaded terrain

I have two sets of terrain data downloaded for offline loading in Cesium JS. My app only uses one set, but I’ve been trying different resolutions. One set of terrain data I created using a bunch of open source tools and that works fine, but there are some data issues that cause visual defects, so I decided to try and create a second terrain data set using Cesium ION and a tiff file. In Cesium ION I saw the option to make the asset downloadable and clicked that. I was thrilled as that’s a lot easier than what I had to go through to create the first data set. However, when I try and use this ION generated terrain set offline, the map constantly crashes and causes the page to refresh. For example terrainProvider: await Cesium.CesiumTerrainProvider.fromUrl('assets/tiles/terrain/NewCastle1m')

If I instead load in this same terrain data set directly from ION it works perfectly/. For example: viewer.scene.setTerrain(new Cesium.Terrain(Cesium.CesiumTerrainProvider.fromIonAssetId(2442403))

There are no errors displayed, the page just refreshes and the map loads. If I try to move the map, the page refreshes again. I suspect there must be an issue with the downloaded tiles.

Here is a link to the TIFF file I used to create the terrain tiles: USGS 1 Meter 10 x56y527 WA_KingCounty_2021_B21 - ScienceBase-Catalog

Hi there,

Glad to see you’re interested in the downloadable assets on ion! However, sad to hear you’re having trouble loading the dataset. At the very least, there should be an error which helps you troubleshoot the issue.

Would you mind giving us a bit more information about how you are serving the downloaded dataset locally? For instance, what’s the file structure on disk?

I’m simply unzipping the downloaded file and copied all files/folders as-is into a folder in my web app, and then serving on localhost since I’m still developing the app.

That said, tried the same app as-is today and it’s working fine. Tried a bunch of different things and couldn’t get the map to crash again. So maybe there was something related to browser cache causing an issue. I’m not sure. I’ll keep an eye out for this to see if it happens again, but for now we can close this thread.

Got it, thanks! Let us know if you see it again.