Play sequencer in game low fps

sequencer_low_fps.rar (19.5 MB)
camera can smoothly move in eidtor sequencer,but in game mode,the fps is very low

1 Like

We can’t really help you without more details. What versions of Unreal Engine and Cesium for Unreal are you using? What exactly is in your scene? If you’re using additional plugins or non-Cesium items, how do those affect performance?

1 Like

you can see what i do in video,when i toggle my sequencer in game and sequence camera move fast,it will be low fps.i am not using any additional plugins or non-cesium items,the project is CesiumforUnrealSamples,the version is ue5.1,the map is 01_CesiumWorld

Video_move camera without sequence.rar (16.7 MB)
here is the another way i find,i can move player pawn in bluepint,it can move very smooth and high fps.
i want high fps when i play sequence just like moving with blueprint.

i have same problem,it happened in play levelsequence.

Cesium for Unreal detects when a sequence is active and it switches into an alternate mode where each render frame waits for all data to load before proceeding. This will indeed drop the frame rate, by a lot. The intention is that sequences are usually used to record videos, and it’s more important to get a high quality recording than it is to record the video quickly.

But it sounds like in your case you’re not using the sequence for video recording, but just to automate changes over time. So in that case, you’ll need to modify Cesium for Unreal itself in order to avoid the slowdown. The logic that detects and switches to special behavior in a sequence is here:

I’m not sure if there’s a way to programmatically distinguish the video case versus the normal play case. If not, the next best thing is probably to add a user-configurable option on the Cesium3DTileset.

If you feel like trying this, we would welcome a pull request.

I wrote an issue to capture it:

thanks kevin,i find a way to avoid this problem.


just toggle “pause movie sequence” when start play sequence.

1 Like

Good find! I updated the issue to mention your workaround.

Thank you so much for this. solved my issue, very simple.