StripeMaterial not clamping

Hi There,

I was experimenting with StripeMaterial to fill some polygons when I noticed that my polygon shapes did not clamp to ground. After switching back to solid color, clamping was back to what was expected.

Before I spend a lot of time trying to figure this one out I wonder if I can get confirmation of whether StripeMaterial in fact disables clamping.

Thank you very much,

Ricardo

Hi Ricardo,

Sounds like this could be a bug. Just to confirm, do you have the polygon height set? If height is defined, ground clamping is disabled.

Best,

  • Rachel

I am using czml for this. For both the position and the polygon positions I am setting the height as 0. If I do not include height, CzmlDataSource gives me errors.

It does clamp to ground as expected when I use solid color material.

Thank you,

Ricardo

Hi Ricardo,

Unfortunately, color is only material type supported for ground primitives currently. Using a different material type will prevent the geometry from clamping. Support for other materials is definitely on our road map, so stay tuned for further updates.

Hope that helps,

  • Rachel

Yeah, that’s what I though. Thanks for confirming.

Since we are in the topic of enhancements, something that I would like to see in the StripeMaterial, is the ability to draw stripes using a pattern of fixed distance between the stripes or perhaps number of stripes per unit of distance. Right now, you have to define the number of stripes for a shape, and if you are drawing (for example) a bunch of polygons representing boundaries, you need to calculate how many stripes per polygon to draw to keep the pattern consistent. Ugh, Not great! Also, having angled stripes would be nice too :slight_smile:

Thanks,

Ricardo

Thanks for the suggestions! These are all options that would definitely be useful, but right now we’re pushing on a lot other big projects (3D Tiles support, internal tiling tools, etc). Rest assured that we’ll get to more material support as soon as we can.

Best,

  • Rachel