There is a problem with the GlobeAwareDefaultPawn moving upward

The GlobeAwareDefaultPawn moves to right when I use Q key.This is not what I want.
I dont upload video because they’re too big

Hi @http3w,

I’m not able to replicate this on my end. I have a few questions to help figure this out:

Are you using the DynamicPawn blueprint that came with the plugin, or building a new character controller from the GlobeAwareDefaultPawn class?

Does the pawn always move to the right when Q is pressed?

Do you have any other input bindings set up in the project settings that could be causing this?

This’s new project,I’m using the DynamicPawn blueprint under the Quickly add basic actor panel


It’s work normally in CesiumforUnrealSamples

Hi @http3w,

I’m guessing this is caused by your input bindings. Go to edit>project settings, then select the Input category. There, you can see if you have any unusual mappings set up.

If you just want to copy the input settings from the Cesium for Unreal Samples project, you can save yourself the trouble of setting up new input bindings for your project.

  1. Close Unreal Editor, and open your file explorer.
  2. Navigate to the Cesium for Unreal project folder, then open the Config subdirectory.
  3. You should see a file called DefaultInput.ini. Copy that file.
  4. Navigate to your project folder and open the Config subdirectory. Paste the DefaultInput.ini file there, overwriting any existing file.
  5. When you open your project again, it should have the same input bindings as the Cesium for Unreal sample project.

Let me know if this helps.
-Alex

I bit of a guess here, but could this problem possibly be caused by the world bounds check? Unreal Engine will try to move a pawn back inside the world bounds if it deems it to be outside them. This can be disabled in the world settings.

thanks for your reply. But I did’t use input bindngs.

thans for your reply. I use the default Apawn. He works normally.So I don’t think this problem can be caused by the world boundary inspection