using geoserver as wms provider, but all I see is a blue globe

I am trying to use geoserver as a wms provider for a small portion of the globe. With the code below I am able to choose the geoserver layer with the baseLayerPicker, but all I get is a completely royal blue globe. The blackMarble provider works as it should.

A few extra points of interest.

  1. I verified that the layer is visible in the geoserver layer preview http://myvm:8083/geoserver/web

  2. I am able to see that the browser is sending requests to the geoserver and getting jpg tiles back for the area of interest. I can also vary the boundaries in the request and get different/expected tiles.

Any ideas or thoughts?

Hello World Cesium Viewer @import url(libs/cesium-1.3/Build/Cesium/Widgets/widgets.css); #cesiumContainer { position: absolute; top: 0; left: 0; height: 100%; width: 100%; margin: 0; overflow: hidden; padding: 0; font-family: sans-serif; }

html {
height: 100%;

body {
padding: 0;
margin: 0;
overflow: hidden;
height: 100%;


Hello maybe you have a CORS issue (

Yes! it was a cors problem, thanks for pointing me in the right direction.

i have the same problem, and i enabled CORS but still doesnt work is there any examples that would help, can`t find the best solution

hi,I have met the same problem with wmts,can you help to solve the problem ,thank you

在 2015年3月13日星期五 UTC+8上午6:48:12,brent…@yahoo.com写道:

Have you put attempted to use the proxy setting for your imagery layer?

Geoserver usually runs on tomcat, so you’ll need something there to enable CORS.

You can confirm its a CORS issue using this plugin in chrome to bypass CORS temporarily and see if it works.

If you’re still getting blue tiles, check the console and see what errors are coming up. Make sure you’re only putting the base WMS url in, without any query parameters like ?getCapabilities.