World Terrain is in blank without any Bing Maps Aerial imagery

Installed Unreal 4.27.2/4.26.2 and the plugin Cesium for Unreal. Account successfully created in Cesium ion and everything seems to work fine with the account.

However when I try to add 3D Tiles or World Terrain or Custom OSM Buildings etc, I always get the same error:

LogEditor: Attempting to add actor of class ‘Cesium3DTileset’ to level at 0.00,0.00,0.00
LogCesium: Loading tileset for asset ID 0
LogCesium: Loading tileset for asset ID 0 done
LogCesium: Error: [2021-12-23 13:25:56.846] [error] [Tileset.cpp:172] Received status code 401 for asset response https://api.cesium.com/v1/assets/0/endpoint

Some clue?

It seems that it is requesting the asset with id=0 and of course it is not available:

Status code 401 means “Unauthorized”, and usually this means that the access token is not valid.

Some debugging steps:

  • Select the “Cesium World Terrain” in the World Outliner. Have a look at the “Details” panel, specifically the “Ion Access Token” field. Does it contain an access token? (I think it should contain one, by default, either a demo-token, or your token when you are logged in and added the actor qith the “Quick Add…” panel)
  • In doubt, go to your tokens page at Cesium ion , select the “Default Token”, copy the token string (on the right) and paste it into the “Ion Access Token” field in the “Details” panel

If this does not help… then we’ll have to take a closer look.

You have already mentioned this, but the most likely reason you are getting this error is because you are trying to access asset ID 0. When you add a Cesium World Terrain actor, in the details panel check what value is listed for Ion Asset ID. If it is 0, try changing it to 1. If you want to add the OSM Buildings then it will be asset ID 96188.

If the first thing I do is adding “Cesium World Terrain + Bing Maps Aerial imagery” I get the error “[Tileset.cpp:172] Received status code 401 for asset response https://api.cesium.com/v1/assets/0/endpoint”. In Details of Cesium World Terrain all is OK. But the scene is in blank without the terrain.

If the first thing I do is adding “Blank 3D Tiles Tileset” I get the error “[Tileset.cpp:172] Received status code 401 for asset response https://api.cesium.com/v1/assets/0/endpoint”. In Details of Cesium3DTileset, asset id is zero and token is empty.

If I manually enter, for example, an asset id = 1 and a valid token, the error is gone. However, I still see nothing, the scene is in blank without the terrain


I’ve done a second account in Cesium ion but the results are the same. It seems that the tokens are valid and it’s not an authorization issue.

Unreal Cesium plugin 1.8.1

Hi @Jesus_Cuadrado,

The error message about asset ID 0 is spurious, and it’s a bug in Cesium for Unreal that we display it. You can ignore it.

It looks like your problem may be that your scene is over-exposed. Sunlight is very bright, so you need to enable “Extend default luminance range in Auto Exposure settings”, as described in step 5 of the quick start:

Kevin

1 Like

You’re right. Now it works properly. Thank you very much!