Xcode building error

I am using unity version - 2022.3f5. I built for IOS, but that time when I ran Xcode, it gave me some errors.

Hi @Gmule,

Can you share what version of Cesium for Unity you’re using? We’re aware of some XCode build issues, but I think they are slightly different issues between versions.

Used Cesium v1.6.1

Hello, Sorry for the inconvenience. A pull request to fix this issue is here: Build XCode project as part of the build process by joseph-kaile · Pull Request #363 · CesiumGS/cesium-unity · GitHub, which hopefully will prevent problems like this happening again.

We have utilized the suggested script in the thread with the name - “BuildCesiumForUnity.cs” and put in in Editor folder. We tried to build a fresh xcode project but end up having same set of errors. Can you please guide me exact steps that I need to perform while making iOS build from Unity using Cesium plugin. What Can i feel it is missing important dependencies.
We had also gone through other conversations in this forum where some of your committee members specified that iOS and WebGL porting is not yet supported.
Looking forward for your help please.

Hello, I would download the Mac package from here ( fix macos build · CesiumGS/cesium-unity@53b8daa (github.com))

and import the tar package from the Unity Package manager, i.e ( Unity - Manual: Install a package from a local tarball file (unity3d.com))

You may have to rename the file extension to be able to select it.

Hopefully this works!

I there. I downloaded the Mac package. I renamed as cesium.tgz. I installed from Unity’s package manager → Install from tarball. and it installs fine. then, building the project, and on Xcode, I get

I’m just running the demo scene

I just tried the package and can confirm it works.

When you built to the project folder, did you Replace or Append?

Also, I don’t see GameAssembly in my Xcode project:

What version of Unity are you using?

This is a wild guess but maybe this may help: https://forum.unity.com/threads/2020-3-1-unable-to-compile-mac-xcode-il2cpp-gameassembly-run-script-build-phase-errors.1083767/

Using Cesium Unity version 1.4.0, I was able to fix this issue.

We just released v1.6.2 today, and hopefully that one will work for you, too. Let us know if it doesn’t.